This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: [Ping] RE: CR16 Port addition


Thank you Richard and David for your thorough review of the CR16 port. 
I have tried to accommodate most of the comments in the modified port 
attached with this mail.

> Logic error: x != 9 || x != 11 => true.
This has been fixed.

> Please delete as many of these as you can.  Since the TARGETM
> structure is now at the end, I suspect you need none of them.
This has been fixed.

> Don't define your ABI based on modes.  Define your ABI in terms of types 
> and sizes.
This has been fixed.

> Extra whitespace.  Check for this all over.
This has been fixed.

> Delete debuging statements.
This has been fixed.

> Huh?  That's not a reg note.
> Try something like add_reg_note (insn, kind, dwarf).
This has been fixed.

> Why use 0, 1, 2 instead of the proper enum rtx_code?
This has been fixed.

> This is part of the ABI, and so should not change based on optimization.
This has been fixed.

> Still unfixed from last review.  Remove this expander and
> rename "adddi3_insn" to "adddi3".  You do not need this.
> 
> Similarly for subdi3, anddi3, iordi3,

Sorry for missing this comment from the last review.
I have fixed it now. 

> "* is deprecated.  Use { } instead.  Many examples.
This has been fixed.

> This should be spelled "maddhisi4" so that it'll be used by generic code.

As per David's suggestion, I have combined RTLs of "smachisi3" and 
"umachisi3". The combined RTL has been assigned the name "<sPat>maddhisi4" 
i.e. depending upon signed/unsigned data types it will be taking name as 
"smaddhisi4" and "umaddhisi4". Is this nomenclature OK?

> Unfixed from last review.  Double parallel.

One more time my apologies for missing this comment from the last review.
I have fixed it now.

> Non-context/unidiffs will not be reviewed.

I assume this is related to missing year '2011' from the file headers.
I have updated all CR16 file headers accordingly.

David had provided important suggestions for avoiding the code duplication 
in cr16.md file. Accordingly, I have combined the addition-subtraction and 
logical operations patterns using mode and code iterators. I request all to
 kindly review these changes as well.


gcc/ChangeLog:
--------------
2011-10-21	Sumanth G <sumanth.gundapaneni@kpitcummins.com>
		Jayant R Sonar <jayant.sonar@kpitcummins.com>
		
	* config.gcc: Add cr16-* support.

	* doc/extend.texi: Document cr16 extensions.
	* doc/install.texi: Document cr16 install.
	* doc/invoke.texi: Document cr16 options.
	* doc/md.texi: Document cr16 constraints.

	* config/cr16/cr16.c: New file.
	* config/cr16/cr16.h: New file.
	* config/cr16/cr16.md: New file.
	* config/cr16/cr16.opt: New file.
	* config/cr16/cr16-libgcc.s: New file.
	* config/cr16/cr16-protos.h: New file.
	
	* config/cr16/divmodhi3.c: New file.
	* config/cr16/predicates.md: New file.
	* config/cr16/constraints.md: New file.
	* config/cr16/t-cr16: New file.
	* config/cr16/unwind-dw2-cr16.c: New file.
	* config/cr16/unwind-dw2.h: New file. 

libgcc/ChangeLog:
-----------------
2011-10-21  Sumanth G <sumanth.gundapaneni@kpitcummins.com>
		Jayant R Sonar <jayant.sonar@kpitcummins.com>

	* config.host: Add National Semiconductor CR16 target (cr16-*-*).
	* config/cr16/crti.S: New file.
	* config/cr16/crtlibid.S: New file.
	* config/cr16/crtn.S: New file.
	* config/cr16/t-cr16: New file.
		
libstdc++-v3/ChangeLog:
-----------------------
2011-10-21  Sumanth G <sumanth.gundapaneni@kpitcummins.com>
		Jayant R Sonar <jayant.sonar@kpitcummins.com>

	*configure: Add National Semiconductor CR16 target (cr16-*-*).		
	
ChangeLog:
----------
2011-10-21  Sumanth G <sumanth.gundapaneni@kpitcummins.com>
		Jayant R Sonar <jayant.sonar@kpitcummins.com>

	* configure.ac: Add National Semiconductor CR16 target.
	* configure: Regenerate
   

Thanks and Regards,
Jayant Sonar
[KPIT Cummins, Pune]

Attachment: cr16-gcc.patch
Description: cr16-gcc.patch


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]