This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [Patch Darwin] rationalize libgcc usage across darwin versions.



On 13 Aug 2010, at 18:43, Mike Stump wrote:


On Aug 13, 2010, at 9:10 AM, IainS wrote:
this removes the _s stub library for darwin10 and the gratuitous link with libgcc.a for darwin > = 9.
The latter is needed on darwin8 for _eprintf (i686,PPC) and save/ restore (PPC).


bootstrapped on i686-darwin{8,9} x86_64-darwin10 and ppc-darwin9 (ppc-darwin8 is past stage1)

OK for trunk & 4.5?

Ok.
trunk r163267
Iain


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]