This is the mail archive of the
mailing list for the GCC project.
Re: [patch i386]: Add for win32 targets pre-prologue profiling feature
On 07/16/2010 11:51 PM, Kai Tietz wrote:
> +#ifndef MCOUNT_NAME_BEFORE_PROLOGUE
> +#define MCOUNT_NAME_BEFORE_PROLOGUE MCOUNT_NAME
I begin to wonder if it wouldn't be better to just go ahead and use
Andi's "__fentry__" symbol for all sub-targets. It's really the only
thing that makes sense given the -mfentry option name.
> + bool force_default_profile_top_flag = (!TARGET_64BIT && flag_pic);
> + default_profile_top_flag = (force_default_profile_top_flag ? 0 : 1);
These are confusing names and definitions, because they don't
correspond to their names. For instance, f_d_p_t_f does not
force the default. It's definition forces p_t_f off.
Do you see what I mean?
> +#ifndef PROFILE_BEFORE_PROLOGUE
> + return false;
> + return true;
Avoid the double negative in favor of the positive.