This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: RFD, draft patch: IRA costs for reg_equiv_invariant regs


Bernd Schmidt wrote:

>> Could use !HARD_REGISTER_P or !HARD_REGISTER_NUM_P here and in a few
>> other places, but we don't seem to have a convention for one or the
>> other, or just a direct compare with FIRST_PSEUDO_REGISTER. Just
>> something I noticed, anyway...
> 
> Compare with FIRST_PSEUDO_REGISTER is more idiomatic IMO.

FWIW, I agree that comparison with FIRST_PSEUDO_REGISTER is what has
traditionally been done -- but I think that using HARD_REGISTER_{NUM_,}P
is better.  It's not that we're likely to ever change how the macro
works, but it does make the code a bit more readable.

In any case, that's not worth much debate; I shan't pursue it.

Are you waiting for any reviews from anyone in particular before
committing this patch?

Thanks,

-- 
Mark Mitchell
CodeSourcery
mark@codesourcery.com
(650) 331-3385 x713


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]