This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [tuples][patch] Tuplify pass_forwprop.


On Thu, Mar 13, 2008 at 1:52 PM, Diego Novillo <dnovillo@google.com> wrote:
> On 3/12/08 7:18 PM, Oleg Ryjkov wrote:
>
>  > +/* Return the rhs of a gimple_assign STMT in a form of a single tree,
>  > +   converted to tyoe TYPE. */
>  > +
>  > +static tree
>  > +rhs_to_tree (tree type, gimple stmt)
>
>  Please add a 'FIXME tuples' comment here: This should disappear, but is
>  needed so we can combine expressions and use the fold() interfaces.
>  Long term, we need to develop folding and combine routines that deal
>  with gimple exclusively.
Done.

>
>  >  /* Propagate from the ssa name definition statements of COND_EXPR
>  > -   in statement STMT into the conditional if that simplifies it.
>  > +   in GIMPLE_COND statement STMT into the conditional if that simplifies it.
>  >     Returns zero if no statement was changed, one if there were
>  >     changes and two if cfg_cleanup needs to run.  */
>  >
>  >  static int
>  > -forward_propagate_into_cond (tree cond_expr, tree stmt)
>
>  The old body for forward_propagate_into_cond doesn't seem to have been
>  removed by your patch.  Maybe I'm misreading the patch, though.
No, it is still there; but was split into two:
forward_propagate_into_cond - to handle the case when stmt is a
GIMPLE_ASSIGN and has the conditional(COND_EXPR) on its rhs.
forward_propagate_into_cond_gimple - the stmt is a GIMPLE_COND itself

>  > @@ -895,26 +988,26 @@ simplify_not_neg_expr (tree stmt)
>  >     the condition which we may be able to optimize better.  */
>  >
>  >  static void
>  > -simplify_switch_expr (tree stmt)
>  > +simplify_switch_expr (gimple stmt)
>
>  s/simplify_switch_expr/simplify_gimple_switch/
Done.

>
>
>  OK with those changes.
OK, I think I'll let Bill go in first, since his change is more substantial.

>
>
>  Diego.
>

Oleg


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]