This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: patch: New pragma command for gcc


Hello,

Thank you for your advice. I modified the patch accordingly.
By the way, I noticed, that structure names and typedefs currently are not 
mentioned in section "names" of coding style. Is this by intension ?

Jakub Jelinek <jakub@redhat.com> wrote on 19.03.2007 14:23:37:

ChangeLog for gcc/testsuite:

2007-03-19  Kai Tietz  <Kai.Tietz@onevision.com>

  * gcc.dg/pragma-push_pop_macro.c: New testcase.

ChangeLog for gcc:

2007-03-19  Kai Tietz  <Kai.Tietz@onevision.com>

  * c-pragma.c: (handle_pragma_push_macro): New functions.
    (handle_pragma_pop_macro): New functions.
    (init_pragma): Add new pragma command.
    (HANDLE_PRAGMA_PUSH_POP_MACRO): Handle macro option
    (def_pushpop_macro): New structure and typedef name
    (pushpop_macro_list): New static variable.

> CamelCase is not the standard GNU variable/type naming convention, see
> http://www.gnu.org/prep/standards/html_node/Names.html#Names

I renamed the structure / typedef name and the global variable name to 
more conforming names.

Regards,
i.A. Kai Tietz

Attachment: gcc_push_pop_macro.txt
Description: Text document

Attachment: gcc_cpragma_c.txt
Description: Text document


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]