This is the mail archive of the
mailing list for the GCC project.
Re: [patch] Record REG_POINTER in more cases
> > * emit-rtl.c (set_mem_attributes_minus_bitpos): Set MEM_POINTER
> > flag.
> > * explow.c (force_not_mem): Set REG_POINTER flag according to
> > MEM_POINTER one.
> > * rtl.h (MEM_POINTER): New macro.
> > (struct rtx_def): Use integrated for MEM_SCALAR_P and frame_related
> > for MEM_POINTER.
> This brings back the 'integrated' field that we had removed when Steven
> removed the RTL inliner from tree-ssa. Could we not use another field?
> Or perhaps rename 'integrated'.
I don't think it should be a problem; I just chose the first field that