This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

PATCH: doc/install.texi and *-*-solaris2


I have installed the following patch to resolve PR bootstrap/10267 both
on mainline and the 3.3 branch.

Thanks for the report!

Gerald

2003-04-05  Gerald Pfeifer  <pfeifer at dbai dot tuwien dot ac dot at>

	PR bootstrap/10267
	* doc/install.texi (*-*-solaris2): /bin/ksh is not just recommended
	for configuring.

Index: doc/install.texi
===================================================================
RCS file: /cvs/gcc/gcc/gcc/doc/install.texi,v
retrieving revision 1.178
diff -u -3 -p -r1.178 install.texi
--- doc/install.texi	2 Apr 2003 22:30:49 -0000	1.178
+++ doc/install.texi	5 Apr 2003 15:45:16 -0000
@@ -3033,12 +3033,12 @@ GCC you first have to install a pre-buil
 @uref{binaries.html,,binaries page} for details.

 The Solaris 2 @command{/bin/sh} will often fail to configure
- at file{libstdc++-v3}, @file{boehm-gc} or
- at file{libjava} dot   If you encounter this problem, set @env{CONFIG_SHELL} to
- at command{/bin/ksh} in your environment before running @command{configure}.
+ at file{libstdc++-v3}, @file{boehm-gc} or @file{libjava}.  We therefore
+recommend to set @env{CONFIG_SHELL} to @command{/bin/ksh} in your
+environment.

 Solaris 2 comes with a number of optional OS packages.  Some of these
-packages are needed to use GCC fully, namely @code{SUNWarc},
+are needed to use GCC fully, namely @code{SUNWarc},
 @code{SUNWbtool}, @code{SUNWesu}, @code{SUNWhea}, @code{SUNWlibm},
 @code{SUNWsprot}, and @code{SUNWtoo}.  If you did not install all
 optional packages when installing Solaris 2, you will need to verify that


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]