This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

[patch] h8300.md: Change insn names.


Hi,

Attached is a patch to change insn names.  addhi3_incdec and
addsi3_incdec don't need their names exposed due to a recent patch to
the h8300 port.  Committed as obvious.

Kazu Hirata

2003-02-20  Kazu Hirata  <kazu at cs dot umass dot edu>

	* config/h8300/h8300.md (addhi3_incdec): Change the name to
	*addhi3_incdec.
	(addsi3_incdec): Change the name to *addsi3_incdec.

Index: h8300.md
===================================================================
RCS file: /cvs/gcc/gcc/gcc/config/h8300/h8300.md,v
retrieving revision 1.172
diff -u -r1.172 h8300.md
--- h8300.md	20 Feb 2003 12:52:14 -0000	1.172
+++ h8300.md	20 Feb 2003 22:58:07 -0000
@@ -827,7 +827,7 @@
   [(set_attr "length" "2,2,2,4,2")
    (set_attr "cc" "none_0hit,none_0hit,clobber,set_zn,set_zn")])
 
-(define_insn "addhi3_incdec"
+(define_insn "*addhi3_incdec"
   [(set (match_operand:HI 0 "register_operand" "=r,r")
 	(unspec:HI [(match_operand:HI 1 "register_operand" "0,0")
 		    (match_operand:HI 2 "incdec_operand" "M,O")]
@@ -876,7 +876,7 @@
    (set (attr "cc")
 	(symbol_ref "compute_plussi_cc (operands)"))])
 
-(define_insn "addsi3_incdec"
+(define_insn "*addsi3_incdec"
   [(set (match_operand:SI 0 "register_operand" "=r,r")
 	(unspec:SI [(match_operand:SI 1 "register_operand" "0,0")
 		    (match_operand:SI 2 "incdec_operand" "M,O")]


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]