This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: Unreviewed h8300 patches


  In message <200108291449.f7TEnxg14904@mail.redhat.com>you write:
  > Hi,
  > 
  > These are all h8300-related patches.  I would greatly appreciate if
  > someone could review these patches.  Starting from the smallest,
  > 
  > http://gcc.gnu.org/ml/gcc-patches/2001-07/msg00897.html
  >   Optimize logical operations by specifying tighter length and cc0.
Basically OK.

I would change the name of emit_logical_op to output_logical_op
(emit generally implies emitting RTL, output generally implies 
 assembly output).

In the HImode code you have:

+         /* Take care of the lower byte.  */
+         if ((det & 0x00ff) != 0)
+           {
+             sprintf (insn_buf, "%s\t%%s2,%%s0", opname);
+             output_asm_insn (insn_buf, operands);
+           }
+         /* Take care of the lower byte.  */
+         if ((det & 0xff00) != 0)
+           {
+             sprintf (insn_buf, "%s\t%%t2,%%t0", opname);
+             output_asm_insn (insn_buf, operands);
+           }

Shouldn't the second comment be "Take care of the upper byte."?


jeff



Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]