This is the mail archive of the gcc-help@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Re: libgccjit.so build fails with ISL enabled


Update: in fact (unless I'm missing something, which is not unlikely),
even turning off ISL still leads to the same error, but during MPC
compilation (see below). Please let me know if I am doing something
incorrectly - I would just like to get a gcc with JIT support an as
little compromises as possible.

Thanks!


$GCC_SRC/configure --enable-languages='c,c++,fortran,go,jit,lto'
--enable-host-shared --without-isl
[...]

/data/pszilard/gcc-build/./prev-gcc/xg++
-B/data/pszilard/gcc-build/./prev-gcc/
-B/opt/tcbsys/gcc/git-39eba41/x86_64-linux-gnu/bin/ -nostdinc++
-B/data/pszilard/gcc-build/prev-x86_64-linux-gnu/libstdc++-v3/src/.libs
-B/data/pszilard/gcc-build/prev-x86_64-linux-gnu/libstdc++-v3/libsupc++/.libs
 -I/data/pszilard/gcc-build/prev-x86_64-linux-gnu/libstdc++-v3/include/x86_64-linux-gnu
 -I/data/pszilard/gcc-build/prev-x86_64-linux-gnu/libstdc++-v3/include
 -I/data/pszilard/gcc.git/libstdc++-v3/libsupc++
-L/data/pszilard/gcc-build/prev-x86_64-linux-gnu/libstdc++-v3/src/.libs
-L/data/pszilard/gcc-build/prev-x86_64-linux-gnu/libstdc++-v3/libsupc++/.libs
  -g -O2 -gtoggle -DIN_GCC -fPIC   -fno-exceptions -fno-rtti
-fasynchronous-unwind-tables -W -Wall -Wno-narrowing -Wwrite-strings
-Wcast-qual -Wmissing-format-attribute -Woverloaded-virtual -pedantic
-Wno-long-long -Wno-variadic-macros -Wno-overlength-strings -Werror
-fno-common  -DHAVE_CONFIG_H -static-libstdc++ -static-libgcc  -o
libgccjit.so.0.0.1 -shared \
             attribs.o jit/dummy-frontend.o jit/libgccjit.o
jit/jit-logging.o jit/jit-recording.o jit/jit-playback.o
jit/jit-result.o jit/jit-tempdir.o jit/jit-builtins.o jit/jit-spec.o
gcc.o libbackend.a libcommon-target.a libcommon.a \
             ../libcpp/libcpp.a ../libdecnumber/libdecnumber.a
libcommon.a ../libcpp/libcpp.a   ../libbacktrace/.libs/libbacktrace.a
../libiberty/pic/libiberty.a ../libdecnumber/libdecnumber.a
-L/data/pszilard/gcc-build/./gmp/.libs
-L/data/pszilard/gcc-build/./mpfr/.libs
-L/data/pszilard/gcc-build/./mpc/src/.libs -lmpc -lmpfr -lgmp
-rdynamic -ldl  -L../zlib -lz \
             driver-i386.o  \
             -Wl,--version-script=../../gcc.git/gcc/jit/libgccjit.map \
             -Wl,-soname,libgccjit.so.0
/usr/bin/x86_64-linux-gnu-ld:
/data/pszilard/gcc-build/./mpc/src/.libs/libmpc.a(acos.o): relocation
R_X86_64_32 against `.rodata.str1.8' can not be used when making a
shared object; recompile with -fPIC
/data/pszilard/gcc-build/./mpc/src/.libs/libmpc.a: error adding
symbols: Bad value
--
SzilÃrd


On Wed, Mar 25, 2015 at 2:32 AM, SzilÃrd PÃll <pszilard@kth.se> wrote:
> I'm having the same issue as the previous poster had back in January,
> namely that configuring with
> --enable-languages='c,c++,fortran,go,jit,lto' --enable-host-shared
> fails. Tried going into the ISL build directory, distclean-ing it and
> reconfiguring with --enable-host-shared, but this in turn led to the
> realization that gmp is also configured carelessly:
>
> $ grep " \$.*/configure " config.log
>   $ /data/pszilard/gcc.git/gmp/configure --srcdir=../../gcc.git/gmp
> --cache-file=./config.cache --prefix=/opt/tcbsys/gcc/git-39eba41
> --enable-host-shared --enable-languages=c,c++,fortran,go,jit,lto
> --program-transform-name=s,y,y, --disable-option-checking
> --build=x86_64-linux-gnu --host=none-pc-linux-gnu
> --target=none-pc-linux-gnu --disable-intermodule
> --enable-checking=yes,types --disable-coverage
> --enable-languages=c,c++,lto --disable-build-format-warnings
> --disable-shared LEX=touch lex.yy.c
>
> Any plans to fix this? Do I have another choice except either tracking
> down all misconfigured dependencies or disabling ISL?
>
> Cheers,
> --
> SzilÃrd


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]