This is the mail archive of the gcc-help@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

problem compiling gcc 4.7.2 under OpenSolaris



Hello,


I have tried to compile gcc 7.4.2 under OpenSolaris but I have failed. First I tried to use the
"native" compilers as I did a number of times (I have successfully compile 4.4.4, 4.5.2, and 4.6.0).
In all my previous compilation I used the following options:


CC=cc CXX=CC /extra/sources/gcc-4.7.2/configure --prefix=/usr --enable-shared --enable-static \
--disable-libtool-lock --target= --enable-objc-gc --disable-libada --enable-libssp \
--enable-languages=c,c++,fortran,go,objc,obj-c++ --enable-threads=posix --enable-tls=yes \
--with-system-zlib --without-gnu-ld --with-ld=/usr/ccs/bin/ld --with-gnu-as --with-as=/usr/sfw/bin/gas \
Â--with-gmp-lib=/usr/lib --with-mpfr-lib=/usr/lib --enable-c99 --enable-nls --enable-wchar_t
--enable-libstdcxx -allocator=mt --with-pic --enable-multilib



The result of the compilation process is:


make[2]: Entering directory `/extra/sources/objdir'
make[3]: Entering directory `/extra/sources/objdir'
rm -f stage_current
make[3]: Leaving directory `/extra/sources/objdir'
Comparing stages 2 and 3
warning: gcc/cc1obj-checksum.o differs
warning: gcc/cc1objplus-checksum.o differs
warning: gcc/cc1plus-checksum.o differs
warning: gcc/cc1-checksum.o differs
Bootstrap comparison failure!
gcc/go/parse.o differs
gcc/go/types.o differs
gcc/go/gogo-tree.o differs
gcc/go/runtime.o differs
gcc/go/go.o differs
gcc/go/dataflow.o differs
gcc/go/unsafe.o differs
gcc/go/statements.o differs
gcc/go/import-archive.o differs
make[2]: *** [compare] Error 1
make[2]: Leaving directory `/extra/sources/objdir'
make[1]: *** [stage3-bubble] Error 2
make[1]: Leaving directory `/extra/sources/objdir'
make: *** [all] Error 2


Now when I try to use either gcc 4.5.2. of 4.6.0 to compile 4.7.2. I am getting the following error:


checking whether the GNU Fortran compiler is working... no
configure: error: GNU Fortran is not working; please report a bug in http://gcc.
gnu.org/bugzilla, attaching /extra/sources/objdir/i386-pc-solaris2.11/libgfortran/config.log



I have compiled and install gmp-5.1.0, mpc-1.0.1, and mpfr-3.1.1. Also, the presense of
cloog-0.17 and isl-0.10 do not affect the compilation at all.


I would really appreciate it if someone would help to resolve this issue.

Best wishes for a Happy New Year,

A.S.



--
Apostolos Syropoulos
Xanthi, Greece





Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]