This is the mail archive of the gcc-help@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: trouble with libgomp/.deps directory building gcc 4.7.2


On 12/18/2012 12:12 PM, Tim Bird wrote:
> I am trying to build gcc-4.7.2 (September tarball release) on Ubuntu 12.04.
> Some ways into the build I get the following error processing the libgomp directory:
> 
> make[3]: Entering directory `/a/home/tbird/work/auto-reduce/lto-work/obj-gcc/x86_64-unknown-linux-gnu/libgomp'
> Makefile:456: .deps/affinity.Plo: No such file or directory
...
> Makefile:480: .deps/work.Plo: No such file or directory
> make[3]: *** No rule to make target `.deps/work.Plo'.  Stop.
> make[3]: Leaving directory `/a/home/tbird/work/auto-reduce/lto-work/obj-gcc/x86_64-unknown-linux-gnu/libgomp'
> make[2]: *** [all-stage1-target-libgomp] Error 2
> make[2]: Leaving directory `/a/home/tbird/work/auto-reduce/lto-work/obj-gcc'
> make[1]: *** [stage1-bubble] Error 2
> make[1]: Leaving directory `/a/home/tbird/work/auto-reduce/lto-work/obj-gcc'
> make: *** [all] Error 2

FYI -  I deleted both my build directory (obj-gcc) and the source directory
(gcc-4.7.2), and tried it with a default './configure' invocation, and it worked
fine.  Then I deleted both directories again and tried it with the original
configure arguments, and it again worked fine.

I'm not sure what the problem was, but I'm not able to reproduce it at
the moment. You can chalk it up to operator error or gamma rays...
 -- Tim

=============================
Tim Bird
Architecture Group Chair, CE Workgroup of the Linux Foundation
Senior Staff Engineer, Sony Network Entertainment
=============================


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]