This is the mail archive of the gcc-help@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Compiler isn't finding system header files


When I compile any program with GCC, specifying that it is a .c file
and that I want to compile it as a C-file to produce a binary, I get -
with any file - something like this :


 "*any source file here* :stdio.h: No such file or directory"


I have the libraries installed, and EVEN if I specify the location of
the file - in a command like -I/usr/lib/include/gcc/i486
-linux-gnu/4.1.2/include/ssp/ (where the system headers are
installed)I still get the output ...


 "*any source file here*:stdio.h: No such file or directory"


where, obviously, stdio.h is a system header file specified by the .c
source file to be compiled with. I don't know much about programming
or anything like that, but I do know that something is wrong somewhere
and that my compiler isn't configured right to find the files... or
something like that.

I have installed, on my system, Debian 4.0 Gnu/Linux with GCC
installed from the CD provided from the Debian distribution site
(debian.org ).  I've struggled at this for hours trying to figure what
is wrong, and I've wasted most of the daylight today trying at this
which is very valuable to me, seeing as winter is approaching and I
get very little daylight as is with school and everything :(

 this is the summary of the output for what I tried to compile here.
It failed to produce the binary.

 gcc -g -I/usr/lib/include/gcc/i486-linux-gnu/4.1.2/include/ssp/ -c
pdf417decode.c
 pdf417decode.c:39:19: error: stdio.h: No such file or directory



If anyone could help, I would be very very gracious so I don't waste
any more time on this problem. It's really giving me headaches.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]