This is the mail archive of the gcc-help@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: error installing previous gcc version


On Nov 22, 2007 12:54 PM, D'arito <espasapalau@gmail.com> wrote:
>
> HI Folks,
> I need to "undergrade" my gcc version that comes with openSuse 10.2 . Well
> the default version is gcc version 4.1.2 20061115 (prerelease) (SUSE Linux).

I tried to install gcc-3.3.3 with gcc-4.3 and had the same error you
did, and that reinforces my first thought:

My first thought is that gcc-3.3.3 is VERY old (especially for C++)
and you are probably trying to deal with old, non-standard code that
need fixing (including gcc-3.3.3).  I've run into the same kinds of
problems with old C and FORTRAN code and eventually had to bite the
bullet:: fix the old code and bring it into the 21st century.  It
sounds like you're fortunate enough to at least have the original
source code, so you can fix it.

But as a last resort, try to find old 3.3.3 binaries, perhaps even
making a clean installation of Fedora Core 2 (or whichever old FC had
3.3.3 as the default gcc).

LOL.

BTW, I think your "mentor" is not keeping up with the times.

-Tom

Tom Browder
Niceville, Florida
USA


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]