This is the mail archive of the
mailing list for the GCC project.
RE: kernel too old
Kaz Kylheku-3 wrote:
> email@example.com wrote:
>> After an update on ubuntu this changed and libc requires at least
> Kernel 2.6 and I get the
>> message "kernel
>> too old"
>> Any suggestions/workarounds too solve this Problem?
> Glibc's minimum kernel requirement is a compile-time option in glibc via
> the configure script. It has absolutely nothing to do with gcc. You have
> to either get a newer kernel, or obtain a glibc that is built to accept
> the kernel that you have. Doh?
Thank you for the quick response!
I'm not able to update the Kernel, so I have to use the old libc or
recompile it with the proper Kernel Version.
I had the old libc.so and ld-linux. So tryed to compile using the old libc.
Which wasn't successful... I got undefined reference errors because I don't
have the old libc headers any more.
I downloaded the old libc package from the ubuntu repository. But even the
older versions need the 2.6 Kernel. probably they updated it?! Crap...
The only way seems to get the source and compile it.
I got the sourcers of the glibc 2.4 which supports only nptl threads. I
don't care I'm not using threads at all. Got it compiled. I didn't got the
"Kernel to old" error on SUSE any more but something else beacuse of the
thraeds. And there is no way to compile glibc without threads support.
It looks like I have to try it with glibc 2.3...
View this message in context: http://www.nabble.com/kernel-too-old-tf3227746.html#a9001651
Sent from the gcc - Help mailing list archive at Nabble.com.