This is the mail archive of the gcc-help@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Build problem with gcc 3.4 on Mac OS X



On Jun 26, 2004, at 4:50 AM, Jim Wilson wrote:


Davide Angelocola wrote:
checking how to run the C preprocessor... /lib/cpp
configure: error: C preprocessor "/lib/cpp" fails sanity check
$ grep cpp gcc/config.log
/Users/davang/gcc-3.4.0/gcc/configure: line 1: /lib/cpp: No such file or directory
configure:2814: /lib/cpp conftest.c

If you look at the gcc/config.log file instead of grepping it, you should see some useful info that might explain the failure.


configure will try "$CC -E" first, if this doesn't work, then I might wonder if something is wrong with the value of CC in your environment.

I don't know why /lib/cpp would be used unless perhaps you have the CPP environment variable set to it, but then that begs the question of why that environment variable is set. It should not be set normally.
Ok, I've looked deeply. There are few interesting lines that should point me to the solution:
configure:2111: gcc -g -O2 -no-cpp-precomp conftest.c >&5
configure:2205: gcc -o conftest -g -O2 -no-cpp-precomp conftest.c >&5
configure:2261: gcc -c -g -O2 -no-cpp-precomp conftest.c >&5
configure:2315: gcc -c -g -O2 -no-cpp-precomp conftest.c >&5
configure:2365: gcc -c -g -no-cpp-precomp conftest.c >&5
configure:2463: gcc -c -g -O2 -no-cpp-precomp conftest.c >&5
configure:2508: gcc -c -g -O2 -no-cpp-precomp conftest.c >&5
***configure:2749: gcc -c -Wno-long-long -no-cpp-precomp conftest.c >&5 ****
configure:2896: result: /usr/bin/cpp
configure:2921: /usr/bin/cpp -no-cpp-precomp conftest.c
configure:2921: /usr/bin/cpp -no-cpp-precomp conftest.c
configure:2995: error: C preprocessor "/usr/bin/cpp" fails sanity check


The test fails when configure try to compile a conftest.c file with -Wno-long-long.

$ CPP="/usr/bin/cpp" make

You may need to delete some config.cache files, and it is probably better to rerun configure than run make. Actually, it is probably best to rm -rf your entire build tree and try again, just to make sure you are getting a clean build.
Yes, I've already tried.

I would suggest trying CPP="cc -E", or whatever $CC is set to instead of using /usr/bin/cpp directly. Or better yet, just set it to an empty string, and let configure determine which program to use as the C preprocessor.
I've tried this too.

Thanks in advance.
 -- Davide Angelocola


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]