This is the mail archive of the gcc-help@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Broken libc problem.


Hello,

I'm trying to compile atk 1.7.1 which requires GLIB 2.0.0 or newer.  I use debian and I had the .deb package libc6-dev 2.2.5 installed (out of date), so I thought I'd upgrade this beforehand by compiling glib 2.4.2.

With the 2 versions of glib installed together (1 as a .deb package, 1 compiled), I tried running configure of atk and it returned the message

*** 'pkg-config --modversion glib-2.0' returned 2.4.2, but GLIB (2.0.1) was found! If pkg-config was correct, then it is best to remove the old version of GLib. You may also be able to fix the error by modifying your LD_LIBRARY_PATH environment variable, or by editing /etc/ld.so.conf. Make sure you have run ldconfig if that is required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH to point to the correct configuration files.

So I uninstalled the .deb packaged libc6-dev 2.2.5 and ran configure again.  This time it returned

configure: checking for C compiler default output
configure: gcc conftest.c >&5
/usr/bin/ld: cannot open crt1.o: No such file or directory
collect2: ld returned 1 exit status
(... bit of test code gcc tried to compile ...)
error: C compiler cannot create executables

and now I'm stuck.  I searched the source directory of glib 2.4.2, but it doesn't have any record of installing crt1.o.  Does that mean there is some other library I must install to enable gcc to "create executables"?
Any help is greatly appreciated.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]