This is the mail archive of the gcc-help@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: isalnum not declared


Eljay,

I actually tried to change the headers, but it did not help (the difference
was that compiler did not go through
/usr/include/c++/3.2.3/backward/iostream.h:32, but the same error occured
again when compiler reached the cctype).

Changing extensions does not seem feasible, because I am using FLEX
(http://www.gnu.org/software/flex/) - the third party code with many .c
files.

The key point, I think, is that compiler does not see 'isalnum' etc in
cctype.  How is it possible?

Thanks,

Nikolai

----- Original Message ----- 
From: "Eljay Love-Jensen" <eljay@adobe.com>
To: "Nikolai Nezlobin" <nezlobin@ece.umn.edu>; <gcc-help@gcc.gnu.org>
Sent: Monday, June 14, 2004 7:44 AM
Subject: Re: isalnum not declared


| Hi Nikolai,
|
| It looks like your old source uses old C++ (pre-ISO 14882 standard) header
| files.  It probably also does not use compliant namespaces.
|
| Change the header files to compliant ones (e.g., #include <iostream.h>
| becomes #include <iostream>).
|
| And add in std:: by either "std::ID"prefix in front of each standard
| namespace identifier (metasyntactically given here as "ID"), or "using
| std::ID" near the top of the source file, or just carte blanche by "using
| namespace std;" after the #include specifier block near the top of the
| source code.
|
| You might also want to change the ".c" extension to ".cpp".
|
| HTH,
| --Eljay
|
|


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]