This is the mail archive of the gcc-bugs@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

[Bug libstdc++/24712] [4.0 Regression] Accidental ABI change between 4.0.1 and 4.0.2?



------- Comment #2 from pcarlini at suse dot de  2005-11-07 16:59 -------
I have to add a comment: all those crashing KDE applications (I looked at the
KDE PRs) are evidently using mt_allocator. Now, mt_allocator is not the alloc
which FSF gcc4.0.x uses by default, the only one for which ABI guarantees are
provided, also about compatibility with gcc3.4.x. I gather therefore that
Debian
is building GCC passing --enable-libstdcxx-allocator=mt, something absolutely
not obvious and not trivial in its consequences.


-- 


http://gcc.gnu.org/bugzilla/show_bug.cgi?id=24712


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]