This is the mail archive of the gcc-bugs@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: ia64-linux binutils requirements?


On Fri, Jul 18, 2003 at 10:16:46AM -0700, Dara Hazeghi wrote:
> 
> --- "H. J. Lu" <hjl@lucon.org> wrote:
> > Binutils 2.14 should be ok for most cases. But the
> > Linux binutils
> > 2.14.90.0.4.1 is a better choice for most Linux
> > people.
> 
> Thanks for the info. Would you mind making a patch for
> doc/install.texi stating as much? Thanks,
> 

Here it is.


H.J.
---
2003-07-17  H.J. Lu <hongjiu.lu@intel.com>

	* doc/install.texi: Update binutils requirement for
	ia64-*-linux.

--- gcc/doc/install.texi.binutils	2003-07-18 10:57:55.000000000 -0700
+++ gcc/doc/install.texi	2003-07-18 10:58:50.000000000 -0700
@@ -2619,6 +2611,11 @@ GCC 3.1 or later is recommended for comp
 As of version 3.1 GCC is believed to be fully ABI compliant, and hence no
 more major ABI changes are expected.
 
+We require binutils 2.14 or newer, 2.14.90.0.4.1 or newer is preferred.
+Previous binutils releases had a number of issues with DWARF 2
+debugging information and other bugs. Also the recent Linux kernel
+requires binutils 2.14.90.0.4.1 or newer.
+
 @html
 <hr />
 @end html


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]