This is the mail archive of the gcc-bugs@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

bootstrap error on Irix 6.1


Hi,
i tried to bootstrap egcs-980824 on Irix 6.1.
Result:
% gtar xzf ~/packageS/Compiler/egcs/egcs-19980824.tar.gz
% mkdir obj
% cd obj
% setenv CC /usr/bin/cc
% setenv CFLAGS -O
% ../egcs-19980824/configure
Configuring for a mips-sgi-irix6.1 host.
Created "Makefile" in /tmp_mnt/home/kahlert/obj using "mh-frag"
:~: Not found
Links are now set up to build a native compiler for mips-sgi-irix6.1
% gmake bootstrap
[....]
egcs-19980824/texinfo/intl -I../../../egcs-19980824/texinfo/lib  -O 
../../../egcs-19980824/texinfo/intl/bindtextdom.c
"../../../egcs-19980824/texinfo/intl/gettextP.h", line 40:
  error(1020): 
identifier "inline" is undefined
static inline nls_uint32

Then I tried this instead:
% setenv CFLAGS '-O -Dinline='
% rm -rf ./*
% ../egcs-19980824/configure
% gmake bootstrap
[....]
for name in _muldi3 _divdi3 _moddi3 _udivdi3 _umoddi3 _negdi2
_lshrdi3 _ashldi3 _ashrdi3 _ffsdi2 _udiv_w_sdiv _udivmoddi4 _cmpdi2
_ucmpdi2 _floatdidf _floatdisf _fixunsdfsi _fixunssfsi _fixunsdfdi
_fixdfdi _fixunssfdi _fixsfdi _fixxfdi _fixunsxfdi _floatdixf
_fixunsxfsi _fixtfdi _fixunstfdi _floatditf __gcc_bcmp _varargs
__dummy _eprintf _bb _shtab _clear_cache _trampoline __main _exit
_ctors _pure; \
do \
  echo ${name}; \
  ./xgcc -B./ -O2   -DIN_GCC    -g -I./include   -g1  -DIN_LIBGCC2
-D__GCC_FLOAT_NOT_NEEDED    -I. -I../../egcs-19980824/gcc
-I../../egcs-19980824/gcc/config -c -DL${name} \
      ../../egcs-19980824/gcc/libgcc2.c -o ${name}.o; \
  if [ $? -eq 0 ] ; then true; else exit 1; fi; \
  ar rc tmplibgcc2.a ${name}.o; \
  rm -f ${name}.o; \
done
_muldi3
_divdi3
_moddi3
_udivdi3
_umoddi3
_negdi2
_lshrdi3
_ashldi3
_ashrdi3
_ffsdi2
../../egcs-19980824/gcc/libgcc2.c: In function `__ffsdi2':
../../egcs-19980824/gcc/libgcc2.c:283: fixed or forbidden register 5
($5) was spilled for class GR_REGS.
This may be due to a compiler bug or to impossible asm
statements or clauses.
gmake[4]: *** [libgcc2.a] Error 1
gmake[4]: Leaving directory `/tmp_mnt/home/kahlert/obj/gcc'
gmake[3]: *** [stmp-multilib-sub] Error 2
gmake[3]: Leaving directory `/tmp_mnt/home/kahlert/obj/gcc'
gmake[2]: *** [stmp-multilib] Error 1
gmake[2]: Leaving directory `/tmp_mnt/home/kahlert/obj/gcc'
gmake[1]: *** [bootstrap] Error 2
gmake[1]: Leaving directory `/tmp_mnt/home/kahlert/obj/gcc'
gmake: *** [bootstrap] Error 2

That's the end of my knowledge.
Bye,
Martin.

-- 
Q: How does a UNIX Guru do Sex ?
A: unzip;strip;touch;finger;mount;fsck;more;yes;umount;sleep


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]