This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: Qt on Linux-AXP

On Tue, 25 Aug 1998 Quant-X Alpha Linux Support wrote:

>[compiling Qt 1.40 under AXP]
>> I tried the egcs-1.1 cvs tree on it as well (most recently on Thursday). Same
>> problems. Do you have any idea what's happening ? Any hint where to look at ?
>> Does egcs generate working shared Qt-libraries on any 64 bit system ? Does any
>> other compiler generate correct libs on the 64 bit systems egcs fails on ?
>I'm not quite shure if we should talk about an egcs bug. 
>I'm not interested in Qt 1.40 (because Qt 1.33 works) but this could
>be a problem in the future. Could you try (or anybody else) to use
>the latest binutil package released by H.J. Lu for building the libs ?
>(Do you remember the scope bug ?)

So I installed binutils-, build a up to date egcs-1.1pre (cvs
sources of last night) and with that build
(target: linux-g++-shared-debug).

Same result:

Built  qt/examples/application/application

> gdb ./application
GNU gdb 4.17
[ license ]
This GDB was configured as "alphaev5-dec-linux-gnu"...
(gdb) run
Starting program: /usr/local/share/qt-1.40/examples/application/./application

Program received signal SIGSEGV, Segmentation fault.
warning: Hit beginning of text section without finding
warning: enclosing function for address 0x48c6d4
This warning occurs if you are debugging a function without any symbols
(for example, in a stripped executable).  In that case, you may wish to
increase the size of the search with the `set heuristic-fence-post' command.

Otherwise, you told GDB there was a function where there isn't one, or
(more likely) you have encountered a bug in GDB.
0x48c6d4 in ?? ()
Current language:  auto; currently c
(gdb) where
#0  0x48c6d4 in ?? ()
#1  0x15555779fd0 in QColor::QColor (this=0x15555b0dab0, r=0, g=0, b=0) at kernel/qcolor.h:132
#2  0x15555779bac in global constructors keyed to color0 () at kernel/qcolor.cpp:87
#3  0x155559c1018 in __do_global_ctors_aux () at ../sysdeps/alpha/elf/crtend.S:75
#4  0x1555574c6ec in _init ()

The constructor QColor::QColor( r, g, b ) just calls QColor::setRgb( r, g, b ),
but it looks like we don't get there ?

  Jochen K"upper

  Heinrich-Heine-Universit"at D"usseldorf
  Institut f"ur Physikalische Chemie I
  Universit"atsstr. 1, Geb 26.43 Raum 02.29    phone ++49-211-8113681
  40225 D"usseldorf                            fax   ++49-211-8115195

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]