This is the mail archive of the gcc-bugs@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: Solaris-- relocation against external symbol


Hi Jeff,

  Thank you for your reply about my problem.

  I installed the binutils-2.9.1 on our Solaris 2.51 system
and the relocation error still happen. So I renamed the /usr/ccs/bin/ld
and linked the new ld to /usr/ccs/bin/ld. Then the following error
poped on the screen.
===
  g++  array.o -o array -L../lib -lblitz -lm
  /opt2/egcs/lib/gcc-lib/sparc-sun-solaris2.5.1/egcs-2.91.52/libgcc.a:
  could not read symbols: Bad value
  collect2: ld returned 1 exit status                                           
===

  Any suggestion?

  Thank you very much.

Kan
kan@egr.msu.edu
 
>   In message <35C26EF4.33B0@aries.tucson.saic.com>you write:
>   > Todd -
>   > 
>   > Yes this is the problem I had.  I never got a reply from
>   > the egcs folks. 
>   > 
>   > As far as I could tell the problem that I had was that
>   > I kept picking up the ld from /usr/ccs/bin.  I wanted to
>   > use the ld from binutils-2.9.1 (a newer ld).  I could never figure
>   > out how to have egcs use the binutils-2.9.1 ld.  I changed PATH,
>   > LD_LIBRARY_PATH, etc.  I tried differing ways of configuring
>   > egcs (--with-gnu-ld, etc).  I tried setting different
>   > egcs environment variables.   I looked at gcc faq's. 
>   > All to no avail.
> Install binutils using the same prefix as you use for egcs.
> 
> This will install a copy of ld (and other programs) into a directory
> that egcs searches before /usr/ccs/bin.
> 
> jeff



Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]