This is the mail archive of the gcc-bugs@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: Internal compiler error


David Mazieres wrote:
> 
> > Date: Tue, 04 Aug 1998 08:01:09 +0200
> > From: Thomas Kunert <kunert@physik.tu-dresden.de>
> >
> > That's funny. For me it compiles without error.
> >
> > Reading specs from /opt/lib/gcc-lib/i586-pc-linux-gnu/egcs-2.91.52/specs
> > gcc version egcs-2.91.52 19980729 (gcc2 ss-980609 experimental)
> 
> Okay, I can now definitely confirm that the bug exists in the latest
> 1.1 branch on both linux and BSD.  I compiled the latest egcs on
> linux, and still see the problem:
> 
> % c++ -c ttinterr.C
> ttinterr.C: In method `int foo<long int>::pub<int>(int)':
> ttinterr.C:20:   instantiated from here
> ttinterr.C:11: Internal compiler error.
> ttinterr.C:11: Please submit a full bug report to `egcs-bugs@cygnus.com'.
> % c++ -v
> Reading specs from /usr/local/egcs/lib/gcc-lib/i686-pc-linux-gnu/egcs-2.91.52/specs
> gcc version egcs-2.91.52 19980803 (gcc2 ss-980609 experimental)
> 
> If the bug got fixed in the 7/29 snapshot, then it must subsequently
> have been reintroduced.
> 
> I guess the other possibility is that you have a non-standard
> installation, modified specs file, environment variable overridding
> the default c++ version, or alias c++ 'c++ -fsomething-strange'.  I
> installed egcs with no customization.  I did do some rudimentary
> fiddling around with options (tried all levels of optimization and
> -fno-exceptions), but always saw the bug.

It was probably my mistake: I have tried it again and I got the same
message
without changing anything in my setup. Perhaps I didn't save the program
properly at the first time.

--
Thomas Kunert


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]