This is the mail archive of the gcc-bugs@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: egcs hangs while compiling klyx-0.9.2



On Fri, 27 Mar 1998, Bernhard Rosenkraenzer wrote:

> Hello,
> egcs and pgcc (current snapshot version for both) hang while trying to
> compile klyx-0.9.2.
> 
> g++ -DHAVE_CONFIG_H -I. -I../././src -I.. -I/usr/kde/include
> -I/usr/src/qt-1.32/include -I/usr/X11R6.3/include -I../images  -g0 -O2
> -fomit-frame-pointer -pipe -s -c lyxfunc.C

Just to add another data point, pgcc could not compile lyxfunc.C from
lyx-0.12.0 (should be the same as the klyx file) *or* the lyxfunc.C file
from any of the prerelease snapshots of lyx I tried (that was a few months
ago). 

Changing "-O2" to "-O0" allowed the compile to complete. I just tried it
today with "gcc version pgcc-2.91.09 980221 (gcc-2.8.0 release)" and
noticed that "-O1" doesn't work either, but "-O0" still does. 
 
Anyway, the upshot is that this is an old problem (hasn't been fixed by
any of the recent pgcc snapshots) that occurs with -O1 but not with -O0. 

The 60k lyxfunc.C file is characterized by large case statements but is
otherwise fairly standard. Hopefully someone out there can figure out
what's going on. 
 
	-Wes Weimer
	wrw3@cornell.edu



Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]