This is the mail archive of the gcc-bugs@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: ./configure broke within the last 24 hour



  In message <Pine.GSO.3.96.980323180230.24249N-100000@alcyone.dbai.tuwien.ac.a
t>you write:
  > On Mon, 23 Mar 1998, Jeffrey A Law wrote:
  > > Yes, we just did an import of texinfo-3.11; I suspect you were trying
  > > to update/build while I was actually doing the import/merge.
  > 
  > Suspecting something like that I did a couple of `cvs updates` spread
  > over at least half an hour...
Well, this isn't a suprise.

CVS is kinda hosed in that if you do a cvs import on a branch and 
a particular imported file hasn't ever changed in the main sources,
then the imported version is made the head version.

This leads to inconsistencies until the merge process is finished
(which can can take a while -- a couple hours isn't uncommon for
import/merge sequences involving the gcc subtree.


  > Right now I tried again: `cvs update` didn't cause any actual
  > change and ./configure still gives me
  > 
  >   Configuring for a sparc-sun-solaris2.6 host.
  >   Created "Makefile" in /sw/swtest/egcs/SOURCETREE/egcs using "mh-frag"
  >   configure: error: can not find sources in . or ..
  >   Configure in /sw/swtest/egcs/SOURCETREE/egcs/texinfo failed, exiting.
  > 
  > I'm afraid there's a real problem.
Hmmm, worked for me last night.

Do you have texinfo/makeinfo/makeinfo.c in your sources?

jeff


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]