This is the mail archive of the gcc-bugs@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Still a problem. Re: m68k-*-*bsd `Internal compiler error' mostly tracked down


In article <u9en0pn7e4.fsf@yorick.cygnus.com> you write:
>This bug is fixed in the development sources and for 1.0.2.

(I sent a private answer to Jason a week ago... still haven't seen anything).
Unfortunately, the situation is more intricate.

It looks like there still is a bug in the current cvs-tree with respect
to m68k-*-*bsd.

In the interim, I've upgraded my base gcc to a working 2.8.0 setup, and tried
recompiling the cvs-current source.

I still get an Internal compiler error in cinst.cc. Same line number. No
ICE number though.  Apparently, g++ gets confused by the same construction.

My understanding is that the 18 december bug that has been fixed since has
unfortunately shadowed a m68k-*-*bsd specific bug that has been introduced
later during egcs development...   

I would need to get much more specific  information concerning the bug
involved in the 18 december change, especially a patch that would fix it
in place, if at all possible, or at least some details, so that I can 
proceed further and try to find when the `new' bug crept in.

So far as I can tell, there is no problem with 1.0.2 pre-release, and it
only affects the implementation of <complex>: if I shunt down this part
with touch stmp-complx bigstmp-complx, gcc proceeds happily to build
an (almost complete) egcs-current system.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]