This is the mail archive of the gcc-bugs@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

egcs-980302 fails on Linux/Alpha kernel


FYI

egcs:
Reading specs from
/usr/lib/gcc-lib/alphaev56-unknown-linux-gnu/egcs-2.91.12/specs
gcc version egcs-2.91.12 980302 (gcc-2.8.0 release)

linux:  2.0.33 + alpha-patches-2.0.33-0.1

The failure:
make[3]: Entering directory `/usr/src/linux/drivers/pci'
gcc -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes -g
-O2 -pipe -mno-fp-regs  -c -o pci.o pci.c
In file included from pci.c:13:
/usr/src/linux/include/linux/bios32.h:58: warning: type defaults to
`int' in declaration of `pcibios_write_config_dword'
gcc: Internal compiler error: program cc1 got fatal signal 6
make[3]: *** [pci.o] Error 1
make[3]: Leaving directory `/usr/src/linux/drivers/pci'


I have tried compiling pci.c by hand a couple times, and it appears it
only crashes when using -O2 (just -g or  -g -O compile).

In case it helps, if I specify -S, the last lines that it puts out
before crashing are:

    jsr $26,pcibios_read_config_dword
    ldgp $29,0($26)
$LM311:
    .stabn 68,0,938,$LM311
    ldl $2,

(the last line is cut off, as you see it)

I'm trying to get a useable development system.  2.7.2.x, which came
installed, doesn't work at all for C++.  egcs-1.0.1 can't compile Qt.
egcs-980302 can compile Qt and all of the code I've tried to date,
except the Kernel.   :-(

Anyone know if 1.0.2-prerelease works?

regards,
Val Gough

PS.  I'm not on this list, so if you need more information, you'll have
to send mail directly.



Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]