This is the mail archive of the gcc-bugs@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

alphapca56 + linux kernel 2.1.89


I was feeling adventurous, so I tried out egcs-980302 on my Alpha 164SX...

I encountered some problems where the ./configure script determined that
my machine was an alphapca56 and then determined it didn't recognize that
kind of machine.

So I edited config.sub, added alphapca56 after alphaev56 (and alphapca56-*
after alphaev56-*), and marched onward.

The next problem I encountered was gcc/configure which tried to define
something as TASK_MAX when I believe it should have been MASK_MAX.

It continued along until the assembler complained about not being able to
use a register it needed for a macro.

I then upgraded to gas-980303, restarted, and everything finished
compiling and installed successfully.

Here's where the fun begins. :)

(As an aside, I sent patches for the problems I encounted to Richard
Henderson...)

I figured the next best test was to try compiling the kernel with '-O6
-mcpu=21164pc' and no '-fomit-frame-pointer'.  Everything worked fine
until I hit pci.c where I got a signal 6.

I recompiled with -E and piped it into a .i file and then tried it again.
It still bombed, even with -O2 and -O.  It finally worked with
optimizations turned off.

I am having trouble with gdb not accepting linux alpha core files... so I
ran gdb against cc1 with the appropriate command line options, and got the
enclosed stack trace.

Anything else I can do to help narrow down this bug?

Jason

bomb.tar.gz


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]