Bug 8799 - [3.2/3.3 regression] ICE: Error reporting routines re-entered.
[3.2/3.3 regression] ICE: Error reporting routines re-entered.
Status: RESOLVED FIXED
Product: gcc
Classification: Unclassified
Component: c++
3.3
: P3 normal
: ---
Assigned To: Gabriel Dos Reis
: ice-on-invalid-code
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-03 08:16 UTC by Robert Schiele
Modified: 2003-07-25 17:33 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Schiele 2002-12-03 08:16:13 UTC
"g++ -c ice.ii" ICEs with the error message:

ice.ii:2: type specifier omitted for parameter `
Internal compiler error: Error reporting routines re-entered.
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.

at the followig illegal codeline:

struct { a(void = 0; a(0), a(0)

Release:
3.2.2 20021202 (prerelease) and 3.3 20021202 (experimental)

Environment:
This bug is independent of system and configuration.

How-To-Repeat:
See description.
Comment 1 Volker Reichelt 2002-12-03 08:32:23 UTC
State-Changed-From-To: open->analyzed
State-Changed-Why: Confirmed.
    
    gcc 2.95.x handles the situation gracefully:
    
      bug.cc:2: type specifier omitted for parameter
      bug.cc:2: parse error at end of input
    
    gcc 3.0.x gets confused:
    
    bug.cc:2: type specifier omitted for parameter
    bug.cc:2: parse error at end of input
    bug.cc:2: confused by earlier errors, bailing out
    
    since 3.1 (also with releases!) we have:
    
      bug.cc:2: type specifier omitted for parameter `
      Internal compiler error: Error reporting routines re-entered.
      Please submit a full bug report,
      with preprocessed source if appropriate.
      See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.
Comment 2 Gabriel Dos Reis 2002-12-03 08:39:57 UTC
Responsible-Changed-From-To: unassigned->gdr
Responsible-Changed-Why: Working on a fix.
Comment 3 Gabriel Dos Reis 2002-12-04 05:49:58 UTC
State-Changed-From-To: analyzed->closed
State-Changed-Why: Fixed in both mainline (3.3) and 3.2 branch