Bug 7186 - DR179 for std::deque::iterator and const_iterator
DR179 for std::deque::iterator and const_iterator
Status: RESOLVED FIXED
Product: gcc
Classification: Unclassified
Component: libstdc++
3.2
: P3 normal
: ---
Assigned To: Paolo Carlini
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-02 12:16 UTC by pcarlini
Modified: 2003-07-25 17:33 UTC (History)
6 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pcarlini 2002-07-02 12:16:09 UTC
This is a follow up of libstdc++/6642, now fixed in the
mainline, concerning std::deque: the resolution of DR179
<Ready> needs to be implemented for operator- of
std::deque::iterator and std::deque::const_iterator too.
This is a testcase, which currently does not compile at all
whereas it should:
//////////
#include <deque>

int main()
{
  std::deque<int> d;
  std::deque<int>::iterator it = d.begin();
  std::deque<int>::const_iterator cit = d.begin();

  return it - cit;
}
//////////

Release:
3.1 and current 3.1.1 and 3.2

Environment:
don't care
Comment 1 pcarlini 2002-07-02 12:16:09 UTC
Fix:
The tricky point is not affecting the behaviour of reverse
iterators about which the status of the relevant DR280
is still <open>.
Comment 2 Benjamin Kosnik 2002-07-03 09:22:56 UTC
Responsible-Changed-From-To: unassigned->paolo
Responsible-Changed-Why: I'm going to give this to you...
Comment 3 Benjamin Kosnik 2002-07-03 09:22:56 UTC
State-Changed-From-To: open->analyzed
State-Changed-Why: Is there a survey of existing practice for this issue? Can all but the reverse_iterator bits go in now, since that will have ABI-impacting effects?
    
    -benjamin
Comment 4 Benjamin Kosnik 2002-07-03 10:11:17 UTC
From: "B. Kosnik" <bkoz@nabi.net>
To: Paolo Carlini <pcarlini@unitus.it>
Cc: bkoz@gcc.gnu.org, gcc-bugs@gcc.gnu.org, gcc-prs@gcc.gnu.org,
   nobody@gcc.gnu.org, paolo@gcc.gnu.org, pcarlini@unitus.it,
   gcc-gnats@gcc.gnu.org
Subject: Re: libstdc++/7186: DR179 for std::deque::iterator and const_iterator
Date: Wed, 3 Jul 2002 10:11:17 -0700

 > >    Is there a survey of existing practice for this issue?
 > >
 > Agreed, I'm going to take care of this, surveying the existing
 > practice of 3 or 4 implementations I have access too.
 
 Great.
 
 > > Can all but the reverse_iterator bits go in now, since that will
 > > have ABI-impacting effects?
 > >
 > Well, as I mentioned in the PR, decoupling the reverse_iterator case 
 > from the "normal" iterator case seems difficult for the special 
 > std::deque::iterator and const_iterator case (it isn't for 
 > __normal_iterator, used by the other standard containers). Again, I
 > will do my best in the next weeks.
 
 Hmm. 
 
 Thanks for looking into this.
 
 -benjamin

Comment 5 pcarlini 2002-07-03 18:28:58 UTC
From: Paolo Carlini <pcarlini@unitus.it>
To: bkoz@gcc.gnu.org,  gcc-bugs@gcc.gnu.org,  gcc-prs@gcc.gnu.org, 
 nobody@gcc.gnu.org,  paolo@gcc.gnu.org,  pcarlini@unitus.it, 
 gcc-gnats@gcc.gnu.org
Cc:  
Subject: Re: libstdc++/7186: DR179 for std::deque::iterator and const_iterator
Date: Wed, 03 Jul 2002 18:28:58 +0200

 bkoz@gcc.gnu.org wrote:
 
 >    Is there a survey of existing practice for this issue?
 >
 Agreed, I'm going to take care of this, surveying the existing practice 
 of 3 or 4 implementations I have access too.
 
 > Can all but the reverse_iterator bits go in now, since that will have ABI-impacting effects?
 >
 Well, as I mentioned in the PR, decoupling the reverse_iterator case 
 from the "normal" iterator case seems difficult for the special 
 std::deque::iterator and const_iterator case (it isn't for 
 __normal_iterator, used by the other standard containers). Again, I will 
 do my best in the next weeks.
 
 Paolo.
 
 http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view%20audit-trail&database=gcc&pr=7186
 
 

Comment 6 pcarlini 2002-07-03 23:28:52 UTC
From: Paolo Carlini <pcarlini@unitus.it>
To: gcc-gnats@gcc.gnu.org,  gcc-prs@gcc.gnu.org,  pcarlini@unitus.it, 
 gcc-bugs@gcc.gnu.org, Benjamin Kosnik <bkoz@redhat.com>
Cc:  
Subject: Re: libstdc++/7186: DR179 for std::deque::iterator and const_iterator
Date: Wed, 03 Jul 2002 23:28:52 +0200

 A little update on the existing practice (as requested by Benjamin):
 - Interestingly, Intel6 (Dinkumware) and Borland5.5.1 (Rogue Wave) show 
 a behaviour identical to that of current mainline v3 that is 6642's 
 testcase is compiled just fine, while 7186's testcase is not.
 - Metrowerks8 is able to compile both (this is the behaviour mandated by 
 the resolution of DR179, according to my reading)
 
 Paolo.
 
 http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view%20audit-trail&database=gcc&pr=7186 
 
 

Comment 7 Benjamin Kosnik 2002-07-04 09:49:35 UTC
From: Benjamin Kosnik <bkoz@redhat.com>
To: pcarlini@unitus.it
Cc: gcc-gnats@gcc.gnu.org, gcc-prs@gcc.gnu.org, gcc-bugs@gcc.gnu.org
Subject: Re: libstdc++/7186: DR179 for std::deque::iterator and const_iterator
Date: Thu, 4 Jul 2002 09:49:35 -0700

 > - Metrowerks8 is able to compile both (this is the behaviour mandated
 > by the resolution of DR179, according to my reading)
 
 I believe this is what v3 should shoot for as well.
 
 -benjamin

Comment 8 Paolo Carlini 2002-07-07 10:15:08 UTC
From: paolo@gcc.gnu.org
To: gcc-gnats@gcc.gnu.org
Cc:  
Subject: libstdc++/7186
Date: 7 Jul 2002 10:15:08 -0000

 CVSROOT:	/cvs/gcc
 Module name:	gcc
 Changes by:	paolo@gcc.gnu.org	2002-07-07 03:15:07
 
 Modified files:
 	libstdc++-v3   : ChangeLog 
 	libstdc++-v3/include/bits: stl_deque.h 
 	libstdc++-v3/testsuite/23_containers: deque_operators.cc 
 
 Log message:
 	2002-07-07  Paolo Carlini  <pcarlini@unitus.it>
 	
 	PR libstdc++/7186
 	* include/bits/stl_deque.h (_Deque_iterator::operator-):
 	Make non-member, as already happens for the comparison
 	operators in accord with DR179 (Ready).
 	* testsuite/23_containers/deque_operators.cc: Add test02.
 
 Patches:
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/ChangeLog.diff?cvsroot=gcc&r1=1.1273&r2=1.1274
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/include/bits/stl_deque.h.diff?cvsroot=gcc&r1=1.22&r2=1.23
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/testsuite/23_containers/deque_operators.cc.diff?cvsroot=gcc&r1=1.2&r2=1.3
 
Comment 9 Benjamin Kosnik 2002-07-24 23:25:44 UTC
State-Changed-From-To: analyzed->feedback
State-Changed-Why: I think you've fixed this, right Paolo?
    
    -benjamin
Comment 10 Paolo Carlini 2002-07-24 23:48:32 UTC
State-Changed-From-To: feedback->closed
State-Changed-Why: Yes, Benjamin, it is fixed for 3.3.
Comment 11 Jakub Jelinek 2002-07-26 23:23:46 UTC
From: jakub@gcc.gnu.org
To: gcc-gnats@gcc.gnu.org
Cc:  
Subject: libstdc++/7186
Date: 26 Jul 2002 23:23:46 -0000

 CVSROOT:	/cvs/gcc
 Module name:	egcs
 Branch: 	gcc-3_2-branch
 Changes by:	jakub@gcc.gnu.org	2002-07-26 16:23:45
 
 Modified files:
 	gcc            : ChangeLog 
 	gcc/cp         : ChangeLog 
 	gcc/testsuite  : ChangeLog 
 	libstdc++-v3   : ChangeLog 
 	gcc/cp         : class.c mangle.c rtti.c decl2.c cp-tree.h 
 	gcc/config/i386: i386.c 
 	gcc/config/mips: mips.c 
 	gcc            : c-decl.c 
 	libstdc++-v3   : configure.in configure 
 	libstdc++-v3/config/locale/generic: monetary_members.cc 
 	libstdc++-v3/config/locale/gnu: monetary_members.cc 
 	libstdc++-v3/src: localename.cc locale.cc 
 	libstdc++-v3/testsuite/22_locale: ctor_copy_dtor.cc 
 	libstdc++-v3/testsuite/24_iterators: iterator.cc 
 	libstdc++-v3/testsuite/27_io: iostream.cc istream.cc ostream.cc 
 	                              ostringstream_members.cc 
 	                              streambuf.cc stringbuf.cc 
 	                              stringstream.cc 
 	                              stringstream_members.cc filebuf.cc 
 	                              istream_unformatted.cc 
 	libstdc++-v3/include/bits: stl_deque.h locale_facets.h 
 	                           stl_iterator.h basic_ios.tcc 
 	                           sstream.tcc streambuf.tcc istream.tcc 
 	libstdc++-v3/include/std: std_istream.h std_streambuf.h 
 	libstdc++-v3/libsupc++: new 
 Added files:
 	gcc/testsuite/g++.dg/abi: layout1.C layout2.C mangle8.C rtti1.C 
 	gcc/testsuite/gcc.c-torture/execute: memset-3.c 
 	gcc/testsuite/gcc.dg: gnu89-init-2.c 
 	libstdc++-v3/testsuite/18_support: new_delete_placement.cc 
 	libstdc++-v3/testsuite/23_containers: deque_operators.cc 
 	libstdc++-v3/testsuite/27_io: fstream.cc ifstream.cc ios.cc 
 	                              istringstream.cc ofstream.cc 
 	                              ostringstream.cc 
 	                              streambuf_members.cc 
 	                              stringbuf_members.cc 
 
 Log message:
 	gcc/ChangeLog
 	
 	2002-07-24  Frank van der Linden  <fvdl@wasabisystems.com>
 	
 	PR optimization/7291
 	* config/i386/i386.c (ix86_expand_clrstr): Fix bzero alignment
 	problem on x86_64.
 	
 	2002-05-16  Jason Merrill  <jason@redhat.com>
 	
 	* config/mips/mips.c (mips_output_external): Don't do sdata
 	optimization for a variable with DECL_COMDAT set.
 	
 	2002-01-03  Jakub Jelinek  <jakub@redhat.com>
 	
 	* c-decl.c (build_compound_literal): Set decl TREE_READONLY from TYPE.
 	
 	* c-decl.c (build_compound_literal): Defer compound literal decls
 	until until file end to emit them only if they are actually used.
 	
 	gcc/cp/ChangeLog
 	
 	2002-07-17  Scott Snyder <snyder@fnal.gov>
 	
 	PR c++/7320
 	* rtti.c (get_tinfo_decl): Set DECL_COMDAT.
 	
 	2002-07-05  Nathan Sidwell  <nathan@codesourcery.com>
 	
 	Repair damage on weak-impared targets caused by my previous patch.
 	* cp-tree.h (import_export_tinfo): Add parameter.
 	* decl2.c (import_export_tinfo): Add parameter, post adjust
 	DECL_COMDAT.
 	* rtti.c (emit_tinfo_decl): DECL_COMDAT is (nearly) always setup by
 	import_export_tinfo.
 	
 	2002-06-30  Nathan Sidwell  <nathan@codesourcery.com>
 	
 	* cp-tree.h (CPTI_TINFO_DECL_TYPE): Replace with ...
 	(CPTI_TYPE_INFO_PTR_TYPE): ... this.
 	(tinfo_decl_type): Replace with ...
 	(type_info_ptr_type): ... this.
 	(import_export_tinfo): Declare.
 	(tinfo_decl_p): Rename to ...
 	(unemitted_tinfo_decl_p): ... this.
 	* decl2.c (import_export_decl): Break out tinfo handling into ...
 	(import_export_tinfo): ... here. New function.
 	(finish_file): Adjust.
 	* rtti.c (TINFO_REAL_NAME): New macro.
 	(init_rtti_processing): Create the tinfo types.
 	(get_tinfo_decl_dynamic): Use type_info_ptr_type, get_tinfo_ptr.
 	(get_tinfo_decl): Adjust.
 	(get_tinfo_ptr): New function.
 	(get_type_id): Use it.
 	(tinfo_base_init): Create vtable decl here, if it doesn't exist.
 	(ptr_initializer): Use get_tinfo_ptr.
 	(ptm_initializer): Likewise.
 	(synthesize_tinfo_var): Break into ...
 	(get_pseudo_ti_init): ... this. Just create the initializer.
 	(get_pseudo_ti_desc): .. and this.
 	(create_real_tinfo_var): Remove.
 	(create_pseudo_type_info): Don't create the vtable decl here.
 	(get_vmi_pseudo_type_info): Remove.
 	(create_tinfo_types): Adjust.
 	(tinfo_decl_p): Rename to ...
 	(unemitted_tinfo_decl_p): ... here. Adjust.
 	(emit_tinfo_decl): Adjust. Create the initializer.
 	
 	2002-06-14  Jason Merrill  <jason@redhat.com>
 	
 	C++ ABI changes.
 	* class.c (build_base_field): Set DECL_PACKED.
 	(layout_class_type): Don't use tail padding of PODs.
 	* mangle.c (write_unqualified_name): Fix template conversion op
 	mangling.
 	
 	2002-05-18  Jason Merrill  <jason@redhat.com>
 	
 	PR c++/6611
 	* decl2.c (import_export_decl): If we clear
 	DECL_NOT_REALLY_EXTERN, make sure DECL_EXTERNAL is set.
 	
 	2002-05-14  Jason Merrill  <jason@redhat.com>
 	
 	* rtti.c (get_tinfo_decl): Don't call comdat_linkage.
 	Do set DECL_COMDAT.
 	(synthesize_tinfo_var): Take the public decl.
 	(create_real_tinfo_var): Likewise.  Check DECL_COMDAT.
 	(emit_tinfo_decl): Adjust.  Call import_export_decl.
 	* decl2.c (import_export_decl): Simplify tinfo decl handling.
 	
 	gcc/testsuite/ChangeLog
 	
 	2002-07-24  Roger Sayle  <roger@eyesopen.com>
 	
 	* gcc.c-torture/execute/memset-3.c: New testcase.
 	
 	2002-06-14  Jason Merrill  <jason@redhat.com>
 	
 	* g++.dg/abi/layout1.C: New test.
 	* g++.dg/abi/layout2.C: New test.
 	* g++.dg/abi/mangle8.C: New test.
 	
 	2002-05-14  Jason Merrill  <jason@redhat.com>
 	
 	* g++.dg/abi/rtti1.C: New test.
 	
 	2002-01-03  Jakub Jelinek  <jakub@redhat.com>
 	
 	* gcc.dg/gnu89-init-2.c: New test.
 	
 	libstdc++-v3/ChangeLog
 	
 	2002-07-26  Phil Edwards  <pme@gcc.gnu.org>
 	
 	* libsupc++/new (placement delete):  Remove unused paramater names.
 	
 	2002-07-25  Benjamin Kosnik  <bkoz@redhat.com>
 	
 	PR libstdc++/7216
 	* include/std/std_istream.h (basic_iostream): Add typedefs for
 	char_type, int_type, pos_type, off_type, and traits_type.
 	* testsuite/27_io/iostream.cc (test01): Add typedef tests.
 	* testsuite/27_io/istream.cc: Same.
 	* testsuite/27_io/ostream.cc: Same.
 	* testsuite/27_io/filebuf.cc: Same.
 	* testsuite/27_io/stringbuf.cc: Replace content, move to...
 	* testsuite/27_io/stringbuf_members.cc: ...here.
 	* testsuite/27_io/streambuf.cc: Replace content, move to...
 	* testsuite/27_io/streambuf_members.cc: ...here.
 	* testsuite/27_io/stringstream.cc: Replace content, move to...
 	* testsuite/27_io/stringstream_members.cc: ...here.
 	* testsuite/27_io/ios.cc: New file.
 	* testsuite/27_io/fstream.cc: New file.
 	* testsuite/27_io/ifstream.cc: New file.
 	* testsuite/27_io/ofstream.cc: New file.
 	* testsuite/27_io/istringstream.cc: New file.
 	* testsuite/27_io/ostringstream.cc: New file.
 	
 	2002-07-25  Benjamin Kosnik  <bkoz@redhat.com>
 	
 	PR libstdc++/7220
 	* include/bits/istream.tcc (istream::ignore): Don't extract on
 	zero.
 	* testsuite/27_io/istream_unformatted.cc (test10): Add.
 	
 	2002-07-24  Benjamin Kosnik  <bkoz@redhat.com>
 	
 	PR libstdc++/7222
 	* src/locale.cc (locale::locale(const char*)): Use setlocale NULL.
 	* testsuite/22_locale/ctor_copy_dtor.cc (test02): New.
 	
 	2002-07-24  Benjamin Kosnik  <bkoz@redhat.com>
 	
 	PR libstdc++/7286
 	* libsupc++/new: Add placement delete.
 	* testsuite/18_support/new_delete_placement.cc: New.
 	
 	2002-07-07  Paolo Carlini  <pcarlini@unitus.it>
 	
 	PR libstdc++/7186
 	* include/bits/stl_deque.h (_Deque_iterator::operator-):
 	Make non-member, as already happens for the comparison
 	operators in accord with DR179 (Ready).
 	* testsuite/23_containers/deque_operators.cc: Add test02.
 	
 	2002-07-04  Benjamin Kosnik  <bkoz@redhat.com>
 	Jack Reeves  <jackw_reeves@hotmail.com>
 	
 	* include/std/std_streambuf.h (basic_streambuf::_M_buf): Change to
 	size_t, from int_type.
 	(basic_streambuf::_M_buf_size_opt): Same.
 	(basic_streambuf::_S_pback_sizex): Same.
 	* include/bits/streambuf.tcc: Same.
 	* include/std/std_streambuf.h (basic_streambuf::snextc): Use
 	eq_int_type.
 	(basic_streambuf::uflow): Same.
 	* include/bits/sstream.tcc (basic_stringbuf::overflow): Use
 	to_char_type.
 	* include/bits/basic_ios.tcc (basic_ios::init): Use _CharT().
 	* include/bits/streambuf.tcc (basic_streambuf::xsgetn): Use
 	eq_int_type.
 	(basic_streambuf::xsputn): Same.
 	(__copy_streambufs): Same.
 	
 	2002-07-02  Paolo Carlini  <pcarlini@unitus.it>
 	
 	PR libstdc++/6642
 	* include/bits/stl_iterator.h
 	(__normal_iterator::operator-(const __normal_iterator&)):
 	Make non-member, as already happens for the comparison
 	operators in accord with DR179 (Ready).
 	* testsuite/24_iterators/iterator.cc: Add test from the PR.
 	
 	2002-07-02  Benjamin Kosnik  <bkoz@redhat.com>
 	
 	PR libstdc++/6410
 	* include/bits/locale_facets.h (moneypunct::moneypunct): Add const
 	char* name parameter.
 	* config/locale/gnu/monetary_members.cc: Use it.
 	* config/locale/generic/monetary_members.cc: Same.
 	* src/localename.cc (_Impl::_Impl(const char*, size_t)): Use it.
 	
 	2002-07-01  Benjamin Kosnik  <bkoz@redhat.com>
 	
 	* configure.in (libtool_VERSION): Bump to 5:0:0.
 	* configure: Regenerate.
 	
 	2002-05-19  Paolo Carlini  <pcarlini@unitus.it>
 	
 	* testsuite/23_containers/deque_operators.cc (test01):
 	Fix minor typo in last commit.
 	
 	2002-05-18  Paolo Carlini  <pcarlini@unitus.it>
 	
 	PR libstdc++/6503
 	* include/bits/stl_deque.h (_Deque_iterator::operator==,
 	operator!=, operator<, operator>, operator>=, operator<=):
 	Make non-member functions, to allow comparing const and
 	non-const iterators in any order.
 	* testsuite/23_containers/deque_operators.cc: New testfile.
 
 Patches:
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/gcc/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.13152.2.657&r2=1.13152.2.657.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/gcc/cp/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.2685.2.114&r2=1.2685.2.114.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/gcc/testsuite/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.1672.2.166&r2=1.1672.2.166.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.1057.2.159&r2=1.1057.2.159.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/gcc/cp/class.c.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.436.2.10&r2=1.436.2.10.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/gcc/cp/mangle.c.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.44.2.5&r2=1.44.2.5.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/gcc/cp/rtti.c.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.130&r2=1.130.6.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/gcc/cp/decl2.c.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.520.2.7&r2=1.520.2.7.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/gcc/cp/cp-tree.h.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.681.2.12&r2=1.681.2.12.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/gcc/config/i386/i386.c.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.368.2.19&r2=1.368.2.19.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/gcc/config/mips/mips.c.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.176.2.6&r2=1.176.2.6.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/gcc/testsuite/g++.dg/abi/layout1.C.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=NONE&r2=1.1.6.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/gcc/testsuite/g++.dg/abi/layout2.C.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=NONE&r2=1.1.6.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/gcc/testsuite/g++.dg/abi/mangle8.C.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=NONE&r2=1.1.6.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/gcc/testsuite/g++.dg/abi/rtti1.C.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=NONE&r2=1.2.8.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/gcc/testsuite/gcc.c-torture/execute/memset-3.c.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=NONE&r2=1.1.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/gcc/testsuite/gcc.dg/gnu89-init-2.c.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=NONE&r2=1.1.4.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/gcc/c-decl.c.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.300.2.10&r2=1.300.2.10.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/configure.in.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.83.2.14&r2=1.83.2.14.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/configure.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.235.2.24&r2=1.235.2.24.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/config/locale/generic/monetary_members.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.1.2.2&r2=1.1.2.2.4.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/config/locale/gnu/monetary_members.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.1.2.2&r2=1.1.2.2.4.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/src/localename.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.24.2.3&r2=1.24.2.3.4.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/src/locale.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.54.2.6&r2=1.54.2.6.4.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/18_support/new_delete_placement.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=NONE&r2=1.1.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/22_locale/ctor_copy_dtor.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.13&r2=1.13.12.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/23_containers/deque_operators.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=NONE&r2=1.3.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/24_iterators/iterator.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.5&r2=1.5.14.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/27_io/fstream.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=NONE&r2=1.1.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/27_io/ifstream.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=NONE&r2=1.1.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/27_io/ios.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=NONE&r2=1.1.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/27_io/istringstream.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=NONE&r2=1.1.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/27_io/ofstream.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=NONE&r2=1.1.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/27_io/ostringstream.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=NONE&r2=1.1.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/27_io/streambuf_members.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=NONE&r2=1.1.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/27_io/stringbuf_members.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=NONE&r2=1.1.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/27_io/iostream.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.1&r2=1.1.24.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/27_io/istream.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.4&r2=1.4.12.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/27_io/ostream.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.4&r2=1.4.12.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/27_io/ostringstream_members.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.2&r2=1.2.20.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/27_io/streambuf.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.10.8.1&r2=1.10.8.1.4.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/27_io/stringbuf.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.7.2.1&r2=1.7.2.1.4.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/27_io/stringstream.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.8&r2=1.8.12.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/27_io/stringstream_members.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.2&r2=1.2.20.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/27_io/filebuf.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.18&r2=1.18.12.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/testsuite/27_io/istream_unformatted.cc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.15.14.2&r2=1.15.14.2.4.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/include/bits/stl_deque.h.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.17.8.2&r2=1.17.8.2.4.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/include/bits/locale_facets.h.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.41.2.2&r2=1.41.2.2.4.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/include/bits/stl_iterator.h.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.19.2.1&r2=1.19.2.1.4.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/include/bits/basic_ios.tcc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.11.2.3&r2=1.11.2.3.4.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/include/bits/sstream.tcc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.8.2.2&r2=1.8.2.2.4.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/include/bits/streambuf.tcc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.12.2.2&r2=1.12.2.2.4.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/include/bits/istream.tcc.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.24.2.6&r2=1.24.2.6.2.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/include/std/std_istream.h.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.3&r2=1.3.14.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/include/std/std_streambuf.h.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.5.2.2&r2=1.5.2.2.4.1
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/egcs/libstdc++-v3/libsupc++/new.diff?cvsroot=gcc&only_with_tag=gcc-3_2-branch&r1=1.9.2.2&r2=1.9.2.2.2.1