Bug 51610 - [OOP] Class container does not properly handle POINTER and TARGET
[OOP] Class container does not properly handle POINTER and TARGET
Status: NEW
Product: gcc
Classification: Unclassified
Component: fortran
4.7.0
: P3 normal
: ---
Assigned To: Not yet assigned to anyone
: accepts-invalid, rejects-valid
Depends on:
Blocks: 51605
  Show dependency treegraph
 
Reported: 2011-12-18 16:56 UTC by Tobias Burnus
Modified: 2013-12-17 16:19 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2013-06-11 00:00:00


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Burnus 2011-12-18 16:56:16 UTC
The following program compiles - but it is invalid.

1. The TARGET attribute is required for "b" and "c"
   But if one tries to set it, one gets an error.
Expected: One can mark them as TARGET and without one gets an error
          for the CALL.

2. The "ptr => x" is invalid as "x" is not TARGET but no error is printed.
3. If one swaps the "x" and the "z" lines, one gets the error:
          ptr => x
          1
  Error: Non-POINTER in pointer association context (pointer assignment)
But one get also an error for the "ptr => y" and "ptr => z" lines.


Related is PR 51605: SELECT TYPE's associate-name needs to set TARGET attribute


       type t
       end type t
       class(t), allocatable :: a(:), b(:), c(:)
! Bogus error: Error: Duplicate TARGET attribute specified
!       target :: a, b, c
       allocate (a(1), b(1), c(1))
                       ! Requires: TARGET attribute - 
       call test(a, b, c) !   possibly not correctly diagnosed
     contains
       subroutine test(x, y, z)
        class(t), pointer, intent(in) :: z(:)
        class(t), target :: y(3)
        class(t) :: x(3)
        class(t), pointer :: ptr(:)
        ptr => x ! Invalid: "x" is not a TARGET
        ptr => y ! Valid: "x" is a TARGET
        ptr => z ! Valid: "z" is a POINTER
       end subroutine
     end
Comment 1 Dominique d'Humieres 2013-06-11 19:16:42 UTC
With 4.8.1 and trunk, I get

pr51610.f90:15.15:

        ptr => x ! Invalid: "x" is not a TARGET
               1
Error: Pointer assignment target is neither TARGET nor POINTER at (1)
pr51610.f90:8.23:

       call test(a, b, c) !   possibly not correctly diagnosed
                       1
Error: Actual argument for 'z' must be a pointer at (1)

Confirmed for 4.7.3. This PR could probably be closed as fixed.
Comment 2 Dominique d'Humieres 2013-06-17 15:06:58 UTC
Waiting.
Comment 3 Dominique d'Humieres 2013-12-14 20:15:09 UTC
No feedback since six months. Closing as FIXED. Please open a new PR if
I have missed any remaining issue.
Comment 4 janus 2013-12-14 22:25:05 UTC
(In reply to Dominique d'Humieres from comment #3)
> No feedback since six months. Closing as FIXED. Please open a new PR if
> I have missed any remaining issue.

AFAICS, we still get the bogus error:

       target :: a, b, c
                     1
Error: Duplicate TARGET attribute specified at (1)
Comment 5 Dominique d'Humieres 2013-12-17 16:19:24 UTC
> AFAICS, we still get the bogus error:
>
>       target :: a, b, c
>                     1
> Error: Duplicate TARGET attribute specified at (1)

Reduced test:

       type t
       end type t
       class(t), allocatable :: a(:), b(:), c(:)
! Bogus error: Error: Duplicate TARGET attribute specified
       target :: a, b, c
     end

There is no error if CLASS is replaced with TYPE or REAL. I still think it would be better to have a new PR opened for it.

BTW I think the test in comment 1 is invalid due to

...
       allocate (a(1), b(1), c(1))
...
        class(t), target :: y(3)
        class(t) :: x(3)
...