Bug 39307 - avr-gcc ICE in start_function, at c-decl.c:6248
avr-gcc ICE in start_function, at c-decl.c:6248
Status: RESOLVED DUPLICATE of bug 34299
Product: gcc
Classification: Unclassified
Component: c
4.3.3
: P3 normal
: ---
Assigned To: Not yet assigned to anyone
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-25 18:46 UTC by John Regehr
Modified: 2009-02-25 18:50 UTC (History)
5 users (show)

See Also:
Host: i686-pc-linux-gnu
Target: avr
Build: i686-pc-linux-gnu
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Regehr 2009-02-25 18:46:14 UTC
Seen in avr-gcc 4.3.3 built using the script that comes with FemtoOS 0.88.

[regehr@babel tmp40]$ avr-gcc -mmcu=atmega128 small.c
small.c:3: internal compiler error: in start_function, at c-decl.c:6248
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.

[regehr@babel tmp40]$ cat small.c

__attribute ((signal))
void __vector_15 (void)
{
}

[regehr@babel tmp40]$ avr-gcc -v

Using built-in specs.
Target: avr
Configured with: ../gcc-4.3.3/configure --prefix=/home/regehr/z/avr-gcc-test --target=avr --with-gnu-ld --with-gnu-as --enable-languages=c,c++ --disable-nls --disable-libssp --with-dwarf2
Thread model: single
gcc version 4.3.3 (GCC)
Comment 1 Andrew Pinski 2009-02-25 18:50:00 UTC

*** This bug has been marked as a duplicate of 34299 ***