Bug 29405 - GCC should include latest GMP/MPFR sources and always build libgmp.a/libmpfr.a
GCC should include latest GMP/MPFR sources and always build libgmp.a/libmpfr.a
Status: RESOLVED WONTFIX
Product: gcc
Classification: Unclassified
Component: other
4.2.0
: P3 enhancement
: ---
Assigned To: Not yet assigned to anyone
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-09 17:14 UTC by Kaveh Ghazi
Modified: 2006-10-14 16:12 UTC (History)
3 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kaveh Ghazi 2006-10-09 17:14:30 UTC
I'm using this to track issues related to including GMP/MPFR in the GCC source tree and building these libraries as part of the bootstrap process.

Initial discussion started here:
http://gcc.gnu.org/ml/gcc/2006-10/msg00136.html
Comment 1 Kaveh Ghazi 2006-10-09 17:18:37 UTC
Initial patch posted here:

http://gcc.gnu.org/ml/gcc-patches/2006-10/msg00416.html

Comment 2 Francois-Xavier Coudert 2006-10-10 08:13:16 UTC
I'm very interested in that. I think it would really benefit the compiler: the Fortran front-end would gain much in stability (and ease of installation) and the C front-end could also benefit from this (as mentionned in PR29335).

What's worrying me a bit is the versioning of MPFR. I'm writing it here because Vincent is in the Cc list of this bug, so maybe he can answer. The last MPFR release is dated 2005-09-09, and since then only patches without version information have been posted. That means we have no way to identify the MPFR library used exactly, to work around potential bugs or require fine-grained minimal version. Vincent, would it be possible that some version number is increased every time a patch is posted, so that the current version would be 2.2.16 or something like that?
Comment 3 Vincent Lefèvre 2006-10-10 13:53:09 UTC
(In reply to comment #2)
> What's worrying me a bit is the versioning of MPFR.

Note that GMP is similar.

> Vincent, would it be possible that some version number is increased every
> time a patch is posted, so that the current version would be 2.2.16 or
> something like that?

There has been a very short discussion about that last year:
  http://sympa.loria.fr/wwsympa/arc/mpfr/2005-12/msg00049.html

The problem is that it is not that simple. First, for some reasons, not all patches committed to the 2.2 branch are put on the 2.2.0 web page, so that the future 2.2.1 version will not just be 2.2.0 + the patches provided on the web page. We could provide another way to identify the patches, but as said in the cited URL, this could be done only as of MPFR 2.3.0 (possibly except if one decides just to add a macro to mpfr.h for this purpose). The main problem is that one may want to apply some patches, but not others, or identify builds from the Subversion repository... For instance, the macro could contain a group of tags (e.g. the name of the patches and possibly some other information). But how would this macro be used by gcc and other software? Would a group of tags be useful, or too complex?
Comment 4 Kaveh Ghazi 2006-10-14 16:09:14 UTC
I think we're converging on not including these libraries in the GCC tree, but rather to require the user to be responsible for getting them.
http://gcc.gnu.org/ml/gcc/2006-10/msg00167.html

Either way, GCC can always rely on MPFR being available, and I can start using it in the middle-end.
Comment 5 Kaveh Ghazi 2006-10-14 16:10:12 UTC
Won't fix.