Bug 24081 - NPE in BasicLabelUI.getPreferredSize (getFontMetrics)
NPE in BasicLabelUI.getPreferredSize (getFontMetrics)
Status: RESOLVED DUPLICATE of bug 24077
Product: classpath
Classification: Unclassified
Component: swing
unspecified
: P2 normal
: ---
Assigned To: Lillian Angel
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-27 09:09 UTC by Norman Hendrich
Modified: 2005-09-27 20:35 UTC (History)
1 user (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2005-09-27 19:17:34


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Norman Hendrich 2005-09-27 09:09:19 UTC
Yet another way to break Swing (classpath cvs 2005.9.27)
Start the classpath Swing demo, then press the 'list' button:

examples/swing> jamvm gnu.classpath.examples.swing.Demo
Exception during event dispatch:
java.lang.NullPointerException
   at gnu.java.awt.peer.gtk.GdkFontMetrics.<init> (GdkFontMetrics.java:69)
   at gnu.java.awt.peer.gtk.GtkToolkit.getFontMetrics (GtkToolkit.java:355)
   at javax.swing.plaf.basic.BasicLabelUI.getPreferredSize (BasicLabelUI.java:11
0)
   at javax.swing.JComponent.getPreferredSize (JComponent.java:1075)
   at javax.swing.plaf.basic.BasicListUI.updateLayoutState (BasicListUI.java:707
)
   at javax.swing.plaf.basic.BasicListUI.maybeUpdateLayoutState (BasicListUI.jav
a:743)
   at javax.swing.plaf.basic.BasicListUI.getCellBounds (BasicListUI.java:617)
   at javax.swing.plaf.basic.BasicListUI.getPreferredSize (BasicListUI.java:895)
   at javax.swing.JComponent.getPreferredSize (JComponent.java:1075)
Comment 1 Thomas Fitzsimmons 2005-09-27 19:17:34 UTC
This looks like a duplicate but I'll let Lillian sort it out.
Comment 2 Lillian Angel 2005-09-27 20:35:04 UTC

*** This bug has been marked as a duplicate of 24077 ***