Bug 23792 - exception when selecting an item from a JComboBox's drop-down menu
exception when selecting an item from a JComboBox's drop-down menu
Status: RESOLVED FIXED
Product: classpath
Classification: Unclassified
Component: swing
unspecified
: P2 normal
: 0.19
Assigned To: Lillian Angel
:
: 19845 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-09 04:31 UTC by Thomas Fitzsimmons
Modified: 2005-09-14 22:38 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2005-09-09 04:35:51


Attachments
test case demonstrating JComboxBox drop-down selection exceptions (570 bytes, text/x-java)
2005-09-09 04:35 UTC, Thomas Fitzsimmons
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Fitzsimmons 2005-09-09 04:31:52 UTC
Selecting an item from a JComboBox drop-down produces this exception:

java.awt.IllegalComponentStateException: component
javax.swing.JPopupMenu$HeavyWeightPopup not showing
   at java.awt.Component.getLocationOnScreen (Component.java:1190)
   at gnu.java.awt.AWTUtilities.convertPointToScreen (AWTUtilities.java:538)
   at gnu.java.awt.AWTUtilities.convertPoint (AWTUtilities.java:596)
   at java.awt.LightweightDispatcher.acquireComponentForMouseEvent
(Container.java:2046)
   at java.awt.LightweightDispatcher.handleEvent (Container.java:2158)
   at java.awt.Container.dispatchEventImpl (Container.java:1630)
   at java.awt.Window.dispatchEventImpl (Window.java:628)
   at java.awt.Component.dispatchEvent (Component.java:2343)
   at java.awt.EventQueue.dispatchEvent (EventQueue.java:475)
   at java.awt.EventDispatchThread.run (EventDispatchThread.java:75)
Comment 1 Thomas Fitzsimmons 2005-09-09 04:35:19 UTC
Created attachment 9697 [details]
test case demonstrating JComboxBox drop-down selection exceptions
Comment 2 Lillian Angel 2005-09-09 20:46:10 UTC
*** Bug 19845 has been marked as a duplicate of this bug. ***
Comment 3 Lillian Angel 2005-09-09 20:47:20 UTC
Same thing happens with ToolTips. Basically anything that pops up and disappears.
Comment 4 Lillian Angel 2005-09-12 16:16:15 UTC
fixed