Bug 18138 - [3.4/4.0 regression] libgcc_s.so.1 not found by 64-bit testsuite
[3.4/4.0 regression] libgcc_s.so.1 not found by 64-bit testsuite
Status: RESOLVED FIXED
Product: gcc
Classification: Unclassified
Component: other
3.4.3
: P2 normal
: 3.4.3
Assigned To: Eric Botcazou
: patch
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-25 03:33 UTC by David Billinghurst
Modified: 2004-10-25 09:25 UTC (History)
1 user (show)

See Also:
Host: mips-sgi-irix6.5
Target: mips-sgi-irix6.5
Build: mips-sgi-irix6.5
Known to work:
Known to fail:
Last reconfirmed: 2004-10-25 03:41:12


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Billinghurst 2004-10-25 03:33:51 UTC
The following patch breaks the 64-bit testsuite for mips-sgi-irix6.5.  I have 
tracked it down in HEAD but the same patch causes a similar problem in the 3.4 
branch. 

2004-11-18  H.J. Lu  <hongjiu.lu@intel.com>

        PR bootstrap/17684
        * Makefile.in (clean): Remove libgcc_s$(SHLIB_EXT).1.stage?.
        (stage1-start): Remove and copy libunwind.a and
        libunwind*$(SHLIB_EXT) instead of libunwind*.
        (stage2-start): Likewise.
        (stage3-start): Likewise.
        (stage4-start): Likewise.
        (stageprofile-start): Likewise.
        (stagefeedback-start): Likewise.

        * config/alpha/t-osf4 (SHLIB_LINK): Use a temporary file for
        the shared library to be created and don't remove the existing
        shared library.
        * config/arm/t-netbsd (SHLIB_LINK): Likewise.
        * config/i386/t-nwld (SHLIB_LINK): Likewise.
        * config/mips/t-slibgcc-irix (SHLIB_LINK): Likewise.
        * config/pa/t-hpux-shlib (SHLIB_LINK): Likewise.
        * config/sh/t-linux (SHLIB_LINK): Likewise.
        * config/t-libunwind-elf (SHLIBUNWIND_LINK): Likewise.
        * config/t-slibgcc-darwin (SHLIB_LINK): Likewise.
        * config/t-slibgcc-elf-ver (SHLIB_LINK): Likewise.
        * config/t-slibgcc-sld (SHLIB_LINK): Likewise.

        * mklibgcc.in (libgcc-stage-start): Also move "*${objext}s"
        files.

After this patch, the -mabi=64 gfortran testsuite reports the error

303790545:./assignment_1.exe: rld: Fatal Error: Cannot Successfully map 
soname 'libgcc_s.so.1' under any of the filenames /disk4/billingd/obj/gcc-
f/gcc/libgcc_s.so.1:./libgcc_s.so.1:/disk4/billingd/obj/gcc-f/mips-sgi-
irix6.5/mabi-
64/libgfortran/.libs/libgcc_s.so.1:/usr/local/lib/libgcc_s.so.1:/usr/lib64/libg
cc_s.so.1:/usr/lib64/internal/libgcc_s.so.1:/lib64/libgcc_s.so.1:/opt/lib64/lib
gcc_s.so.1: 

and a similar problem occurs with the g++ testsuite.

Before the patch and configured with --enable-languages=c,f95 the follwoing 
shared libraries are built.

./gcc/libgcc_s.so
./gcc/libgcc_s_mabi-64.so
./gcc/libgcc_s_mabi-32.so
./gcc/libgmp.so.4
./gcc/mabi-32/libgcc_s.so.1
./gcc/mabi-64/libgcc_s.so.1
./gcc/libgcc_s.so.1
./mips-sgi-irix6.5/libgfortran/.libs/libgfortran.so.1.0
./mips-sgi-irix6.5/libgfortran/.libs/libgfortran.so.1
./mips-sgi-irix6.5/libgfortran/.libs/libgfortran.so
./mips-sgi-irix6.5/mabi-32/libgfortran/.libs/libgfortran.so.1.0
./mips-sgi-irix6.5/mabi-32/libgfortran/.libs/libgfortran.so.1
./mips-sgi-irix6.5/mabi-32/libgfortran/.libs/libgfortran.so
./mips-sgi-irix6.5/mabi-64/libgfortran/.libs/libgfortran.so.1.0
./mips-sgi-irix6.5/mabi-64/libgfortran/.libs/libgfortran.so.1
./mips-sgi-irix6.5/mabi-64/libgfortran/.libs/libgfortran.so


after the patch I get

find . -name "*.so*"
./gcc/libgcc_s.so
./gcc/libgcc_s.so.1.stage1
./gcc/libgcc_s_mabi-32.so
./gcc/libgmp.so.4
./gcc/libgcc_s.so.1.stage2
./gcc/mabi-32/libgcc_s.so.1.stage2
./gcc/mabi-32/libgcc_s.so.1
./gcc/mabi-64/libgcc_s.so.1.stage2
./gcc/mabi-64/libgcc_s.so.1
./gcc/libgcc_s_mabi-64.so
./gcc/libgcc_s.so.1
./mips-sgi-irix6.5/libgfortran/.libs/libgfortran.so.1.0
./mips-sgi-irix6.5/libgfortran/.libs/libgfortran.so.1
./mips-sgi-irix6.5/libgfortran/.libs/libgfortran.so
./mips-sgi-irix6.5/mabi-32/libgfortran/.libs/libgfortran.so.1.0
./mips-sgi-irix6.5/mabi-32/libgfortran/.libs/libgfortran.so.1
./mips-sgi-irix6.5/mabi-32/libgfortran/.libs/libgfortran.so
./mips-sgi-irix6.5/mabi-64/libgfortran/.libs/libgfortran.so.1.0
./mips-sgi-irix6.5/mabi-64/libgfortran/.libs/libgfortran.so.1
./mips-sgi-irix6.5/mabi-64/libgfortran/.libs/libgfortran.so
Comment 1 Andrew Pinski 2004-10-25 03:41:12 UTC
Confirmed, Eric Botcazou posted a patch here: <http://gcc.gnu.org/ml/gcc-patches/2004-10/
msg02011.html> to fix the problem.
Comment 2 david.billinghurst@comalco.riotinto.com.au 2004-10-25 03:56:11 UTC
Subject: RE:  [3.4/4.0 regression] libgcc_s.so.1 not found by 64-bit testsuite

The gfortran.exp part works for me on mips-sgi-irix6.5.  Will try the rest overnight.

	David


NOTICE
This e-mail and any attachments are private and confidential and may contain privileged information. If you are not an authorised recipient, the copying or distribution of this e-mail and any attachments is prohibited and you must not read, print or act in reliance on this e-mail or attachments.
This notice should not be removed.
Comment 3 Eric Botcazou 2004-10-25 06:09:51 UTC
This is the same problem as on Solaris.  I should have done my homework...
Comment 4 CVS Commits 2004-10-25 09:01:26 UTC
Subject: Bug 18138

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	ebotcazou@gcc.gnu.org	2004-10-25 09:01:15

Modified files:
	gcc/testsuite  : ChangeLog 
	libffi         : ChangeLog 
	libjava        : ChangeLog 
	libmudflap     : ChangeLog 
	libstdc++-v3   : ChangeLog 
	gcc/testsuite/lib: g++.exp gcc-dg.exp gfortran.exp objc.exp 
	                   treelang.exp 
	libffi/testsuite/lib: libffi-dg.exp 
	libjava/testsuite/lib: libjava.exp 
	libmudflap/testsuite/lib: libmudflap.exp 
	libstdc++-v3/testsuite/lib: libstdc++.exp 

Log message:
	gcc/testsuite:
	PR other/18138
	* lib/g++.exp: Accept more than one multilib libgcc.
	* lib/gcc-dg.exp: Likewise.
	* lib/objc.exp: Likewise.
	* lib/treelang.exp: Likewise.
	* lib/gfortran.exp: Likewise.
	
	libffi:
	PR other/18138
	* testsuite/lib/libffi-dg.exp: Accept more than one multilib
	libgcc.
	
	libjava:
	PR other/18138
	* testsuite/lib/libjava.exp: Accept more than one multilib
	libgcc.
	
	libmudflap!:
	PR other/18138
	* testsuite/lib/libmudflap.exp: Accept more than one multilib
	libgcc.
	
	libstdc++-v3:
	PR other/18138
	* testsuite/lib/libstdc++.exp: Accept more than one multilib
	libgcc.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/ChangeLog.diff?cvsroot=gcc&r1=1.4491&r2=1.4492
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libffi/ChangeLog.diff?cvsroot=gcc&r1=1.200&r2=1.201
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libjava/ChangeLog.diff?cvsroot=gcc&r1=1.3166&r2=1.3167
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libmudflap/ChangeLog.diff?cvsroot=gcc&r1=1.36&r2=1.37
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/ChangeLog.diff?cvsroot=gcc&r1=1.2719&r2=1.2720
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/lib/g++.exp.diff?cvsroot=gcc&r1=1.41&r2=1.42
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/lib/gcc-dg.exp.diff?cvsroot=gcc&r1=1.35&r2=1.36
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/lib/gfortran.exp.diff?cvsroot=gcc&r1=1.6&r2=1.7
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/lib/objc.exp.diff?cvsroot=gcc&r1=1.26&r2=1.27
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/lib/treelang.exp.diff?cvsroot=gcc&r1=1.4&r2=1.5
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libffi/testsuite/lib/libffi-dg.exp.diff?cvsroot=gcc&r1=1.8&r2=1.9
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libjava/testsuite/lib/libjava.exp.diff?cvsroot=gcc&r1=1.59&r2=1.60
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libmudflap/testsuite/lib/libmudflap.exp.diff?cvsroot=gcc&r1=1.5&r2=1.6
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/testsuite/lib/libstdc++.exp.diff?cvsroot=gcc&r1=1.26&r2=1.27

Comment 5 CVS Commits 2004-10-25 09:22:53 UTC
Subject: Bug 18138

CVSROOT:	/cvs/gcc
Module name:	gcc
Branch: 	gcc-3_4-branch
Changes by:	ebotcazou@gcc.gnu.org	2004-10-25 09:22:46

Modified files:
	gcc/testsuite  : ChangeLog 
	libffi         : ChangeLog 
	libjava        : ChangeLog 
	libstdc++-v3   : ChangeLog 
	gcc/testsuite/lib: g++.exp g77.exp objc.exp 
	libffi/testsuite/lib: libffi-dg.exp 
	libjava/testsuite/lib: libjava.exp 
	libstdc++-v3/testsuite/lib: libstdc++.exp 

Log message:
	gcc/testsuite:
	PR other/18138
	* lib/g++.exp: Accept more than one multilib libgcc.
	* lib/objc.exp: Likewise.
	* lib/g77.exp: Likewise.
	
	libffi:
	PR other/18138
	* testsuite/lib/libffi-dg.exp: Accept more than one multilib
	libgcc.
	
	libjava:
	PR other/18138
	* testsuite/lib/libjava.exp: Accept more than one multilib
	libgcc.
	
	libstdc++-v3:
	PR other/18138
	* testsuite/lib/libstdc++.exp: Accept more than one multilib
	libgcc.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.3389.2.295&r2=1.3389.2.296
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libffi/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.153.4.10&r2=1.153.4.11
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libjava/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.2562.2.24&r2=1.2562.2.25
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/ChangeLog.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.2224.2.190&r2=1.2224.2.191
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/lib/g++.exp.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.35&r2=1.35.4.1
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/lib/g77.exp.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.17&r2=1.17.4.1
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/lib/objc.exp.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.20&r2=1.20.4.1
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libffi/testsuite/lib/libffi-dg.exp.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.7.4.1&r2=1.7.4.2
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libjava/testsuite/lib/libjava.exp.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.57&r2=1.57.4.1
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libstdc++-v3/testsuite/lib/libstdc++.exp.diff?cvsroot=gcc&only_with_tag=gcc-3_4-branch&r1=1.15.4.6&r2=1.15.4.7

Comment 6 Eric Botcazou 2004-10-25 09:25:13 UTC
See http://gcc.gnu.org/ml/gcc-patches/2004-10/msg02011.html