Bug 11227 - [ia64] ICE for _Complex float, _Complex long double args
[ia64] ICE for _Complex float, _Complex long double args
Status: RESOLVED FIXED
Product: gcc
Classification: Unclassified
Component: target
3.3
: P2 normal
: 3.3.3
Assigned To: Not yet assigned to anyone
: ice-on-valid-code
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-17 22:48 UTC by janis187
Modified: 2004-01-15 23:50 UTC (History)
1 user (show)

See Also:
Host: ia64-unknown-linux-gnu
Target: ia64-unknown-linux-gnu
Build: ia64-unknown-linux-gnu
Known to work:
Known to fail:
Last reconfirmed: 2003-12-29 02:21:01


Attachments
test case (114 bytes, text/plain)
2003-06-17 22:50 UTC, janis187
Details
test case 2 (193 bytes, text/plain)
2003-06-17 22:51 UTC, janis187
Details
test case 3 (265 bytes, text/plain)
2003-06-17 22:52 UTC, janis187
Details
test case 4 (165 bytes, text/plain)
2003-06-17 22:52 UTC, janis187
Details

Note You need to log in before you can comment on or make changes to this bug.
Description janis187 2003-06-17 22:49:00 UTC
The following tests (new since GCC 3.3) cause GCC to ICE for
ia64-linux while processing objects of type "_Complex float" and
_Complex long double".  These are not regressions, the problems have
apparently existed since _Complex was added.

FAIL: gcc.dg/compat/scalar-by-value-3 c_compat_x_tst.o compile
FAIL: gcc.dg/compat/scalar-by-value-4 c_compat_x_tst.o compile
FAIL: gcc.dg/compat/scalar-return-3 c_compat_x_tst.o compile
FAIL: gcc.dg/compat/struct-by-value-16 c_compat_x_tst.o compile
FAIL: gcc.dg/compat/struct-by-value-16 c_compat_y_tst.o compile
FAIL: gcc.dg/compat/struct-by-value-18 c_compat_x_tst.o compile
FAIL: gcc.dg/compat/struct-by-value-5 c_compat_x_tst.o compile

The attached minimized test cases duplicate the ICEs from the
original tests.  Output with gcc version 3.4 20030617 (experimental):

--- bug2.c ---
bug2.c: In function `testitcld':
bug2.c:8: internal compiler error: in gen_movtf, at insn-emit.c:2556
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
--- bug3a.c ---
bug3a.c: In function `testScf7':
bug3a.c:9: internal compiler error: in emit_move_insn, at expr.c:3262
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
--- bug3b.c ---
bug3b.c: In function `test2_cf':
bug3b.c:9: internal compiler error: in emit_move_insn, at expr.c:3262
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
--- bug4.c ---
bug4.c: In function `checkScf7':
bug4.c:7: internal compiler error: in convert_move, at expr.c:573
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.

Two of the ICE messages are the same, but the test cases might get
there by different routes so they're both included.
Comment 1 janis187 2003-06-17 22:50:50 UTC
Created attachment 4238 [details]
test case
Comment 2 janis187 2003-06-17 22:51:38 UTC
Created attachment 4239 [details]
test case 2
Comment 3 janis187 2003-06-17 22:52:09 UTC
Created attachment 4240 [details]
test case 3
Comment 4 janis187 2003-06-17 22:52:43 UTC
Created attachment 4241 [details]
test case 4
Comment 5 Dara Hazeghi 2003-06-20 07:01:53 UTC
I can confirm that testcases 2-4 ICE on ia64-hpux with gcc 3.2.3, 3.3 branch and mainline. The 
first testcase however does not ICE for me. I wonder why...
Comment 6 Steve Ellcey 2004-01-15 23:44:10 UTC
This is caused by the same problem that created bug 11226 and is fixed by the
same patch.  This patch is on the ToT and the 3.3 branch.  I tested ToT and
3.3.2 with the patch from
http://gcc.gnu.org/ml/gcc-patches/2003-12/msg00145.html and all the test cases
worked so this defect should be closed out.
Comment 7 Wolfgang Bangerth 2004-01-15 23:48:16 UTC
Fixed according to Steve.